BBB QtCreator LCD4 Cape, Small Problem.

Please could someone help me, It has taken me weeks to get to this stage.

I have successfully set up a QT Creator development suite and can remote deploy my programs.
Everything works i.e the touch screen and mouse work.

But when I run my programs from a terminal with -qws the mouse doesn’t work,

If I export the paths for the touch screen then it will work.

I have tried to run a script on start up to export the correct paths but still dosent help.

What have I missed?


I had a similar problem running the QT demo Fingerpaint using the linux frame buffer (-platform linuxfb)
It turned out I did not have permissions to read the /dev/input/event*
Try running the app as root or launch using sudo
If that solves the problem, change the group for /dev/input/event* and add permissions for that group to your user.

Read this:

Thank you for your help, much appreciated.

Just getting my development platform up and running was a struggle.

Could any of you help me with a QT program to display the temperature from a

BMP085? My c++ skills are my shortfall. How ever I have been making simple gui’s.