BBB related issues

We got our BBB a while back and have been having consistent issues. We have repeatedly tried to flash images onto the BBB, and we’ve been unsuccessful. We followed the instructions here, here, and here, but nothing works. When trying to write the image onto the driver, it took over 6 hours, and never finished. Now we are unable to even shut it down properly. We’ve repeatedly tried to flash the image onto the BBB using Balena Etcher, we’ve tried with and without the SD card. We’ve tried using the commands to make them shut down and reboot, but those don’t work. It worked like maybe the 17th time we tried it, but now it doesn’t work again. We’ve tried to do this on 4 different computers, with multiple different USB cords, but it hasn’t worked. Could this be a possible hardware issue, or are we missing something super obvious?

Hi @cattack let’s start with the basic, what is the image “name” you are trying to flash?


Possibly you need a power supply to the 5V jack in addition to the USB.

We’ve always had it hooked up to a power source as indicated in the instructions.

Apologies, my reply was not saved for some reason. We’ve attempted to use images listed for the BBB that we have found here: - latest-images