BBB Rev C is not booting without pressing user button

Hi Guys,

I am struggling very much to kick start my BBB rev C. When I power ON the board it does not boot, cant see user LED’s blinking. Its only booting when SD card is inserted and press and hold user button and power ON. I tried almost all the methods such as 1. Debian flasher image, 2. Debian sd card image 3. I tried Debian: Getting Started with the BeagleBone Black - Linux Guides - Engineering and Component Solution Forum - TechForum │ Digi-Key but nothing is working. It also takes more than 7-8 minutes to boot from SD card dont know why?. I suspect problem in NAND flash but how to fix it dont know. please help me out from this. Thank you very much

Hi @MKD , do you have a USB serial adapter attached to J1, so we can debug what happens on bootup?

https://elinux.org/Beagleboard:BeagleBone_Black_Serial

If so please, share your current “boot” log…

Regards,

Hi Robert,

Please find below the logs for Debian SD card 10.3 image

CCCCCCCC                                                                     
U-Boot SPL 2019.04-00002-g07d5700e21 (Mar 06 2020 - 11:24:55 -0600)          
Trying to boot from MMC1                                                     
Loading Environment from EXT4... ** File not found /boot/uboot.env **        
                                                                             
** Unable to read "/boot/uboot.env" from mmc0:1 **
                                        
                                        
U-Boot 2019.04-00002-g07d5700e21 (Mar 06 2020 - 11:24:55 -0600), Build: jenkins7
                                        
CPU  : AM335X-GP rev 2.1                
I2C:   ready
DRAM:  512 MiB
No match for driver 'omap_hsmmc'
No match for driver 'omap_hsmmc'                                                
Some drivers were not found                                                     
Reset Source: Power-on reset has occurred.                                      
RTC 32KCLK Source: External.                                                    
MMC:   OMAP SD/MMC: 0, OMAP SD/MMC: 1                                           
Loading Environment from EXT4... ** File not found /boot/uboot.env **           
                                                                                
** Unable to read "/boot/uboot.env" from mmc0:1 **                              
Board: BeagleBone Black                                                         
<ethaddr> not set. Validating first E-fuse MAC                                  
BeagleBone Black:                                                               
BeagleBone: cape eeprom: i2c_probe: 0x54:                                       
BeagleBone: cape eeprom: i2c_probe: 0x55:                                       
BeagleBone: cape eeprom: i2c_probe: 0x56:                                       
BeagleBone: cape eeprom: i2c_probe: 0x57:                                       
Net:   eth0: MII MODE                                                           
cpsw, usb_ether                                                                 
Press SPACE to abort autoboot in 0 seconds                                      
board_name=[A335BNLT] ...                                                       
board_rev=[000C] ...                                                            
switch to partitions #0, OK                                                     
mmc0 is current device                                                          
SD/MMC found on device 0                                                        
switch to partitions #0, OK                                                     
mmc0 is current device                                                          
Scanning mmc 0:1...                                                             
gpio: pin 56 (gpio 56) value is 0                                               
gpio: pin 55 (gpio 55) value is 0                                               
gpio: pin 54 (gpio 54) value is 0                                               
gpio: pin 53 (gpio 53) value is 1                                               
switch to partitions #0, OK                                                     
mmc0 is current device                                                          
gpio: pin 54 (gpio 54) value is 1                                               
Checking for: /uEnv.txt ...                                                     
Checking for: /boot.scr ...                                                     
Checking for: /boot/boot.scr ...                                                
Checking for: /boot/uEnv.txt ...                                                
gpio: pin 55 (gpio 55) value is 1                                               
2062 bytes read in 35 ms (56.6 KiB/s)                                           
Loaded environment from /boot/uEnv.txt                                          
Checking if uname_r is set in /boot/uEnv.txt...                                 
gpio: pin 56 (gpio 56) value is 1                                               
Running uname_boot ...                                                          
loading /boot/vmlinuz-4.19.94-ti-r42 ...                                        
10095592 bytes read in 663 ms (14.5 MiB/s)                                      
debug: [enable_uboot_overlays=1] ...                                            
debug: [enable_uboot_cape_universal=1] ...                                      
debug: [uboot_base_dtb_univ=am335x-boneblack-uboot-univ.dtb] ...                
uboot_overlays: [uboot_base_dtb=am335x-boneblack-uboot-univ.dtb] ...            
uboot_overlays: Switching too: dtb=am335x-boneblack-uboot-univ.dtb ...          
loading /boot/dtbs/4.19.94-ti-r42/am335x-boneblack-uboot-univ.dtb ...           
162266 bytes read in 63 ms (2.5 MiB/s)                                          
uboot_overlays: [fdt_buffer=0x60000] ...                                        
uboot_overlays: loading /lib/firmware/BB-ADC-00A0.dtbo ...                      
867 bytes read in 173 ms (4.9 KiB/s)                                            
uboot_overlays: loading /lib/firmware/BB-BONE-eMMC1-01-00A0.dtbo ...            
1584 bytes read in 343 ms (3.9 KiB/s)                                           
uboot_overlays: loading /lib/firmware/BB-HDMI-TDA998x-00A0.dtbo ...             
4915 bytes read in 264 ms (17.6 KiB/s)                                          
uboot_overlays: loading /lib/firmware/AM335X-PRU-RPROC-4-19-TI-00A0.dtbo ...    
3801 bytes read in 471 ms (7.8 KiB/s)                                           
loading /boot/initrd.img-4.19.94-ti-r42 ...                                     
6589689 bytes read in 445 ms (14.1 MiB/s)                                       
debug: [console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/m.
debug: [bootz 0x82000000 0x88080000:648cf9 88000000] ...                        
## Flattened Device Tree blob at 88000000                                       
   Booting using the fdt blob at 0x88000000                                     
   Loading Ramdisk to 8f9b7000, end 8ffffcf9 ... OK                             
   Loading Device Tree to 8f92b000, end 8f9b6fff ... OK                         
                                                                                
Starting kernel ...                                                             
                                                                                
[    0.002163] timer_probe: no matching timers found                            
[    0.195793] l4_wkup_cm:clk:0010:0: failed to disable                         
[    1.415189] omap_voltage_late_init: Voltage driver support not added         
                                                                                
Debian GNU/Linux 10 beaglebone ttyS0                                            
                                       
default username:password is [debian:temppwd]                                   
                                                                                
beaglebone login: [   56.937532] wkup_m3_ipc 44e11324.wkup_m3_ipc: could not gee

Your eMMC is blank…

Feel free to use balenaEtcher - Flash OS images to SD cards & USB drives and write this image to an microSD:

https://rcn-ee.net/rootfs/bb.org/testing/2021-05-28/buster-iot/bone-eMMC-flasher-debian-10.9-iot-armhf-2021-05-28-4gb.img.xz

  • Insert Card
  • Hold Down boot button
  • Insert Power
  • Lift Finger on boot button
  • Should see cylon pattern

Board should shutdown in 5-10 minutes when done flashing… Remove microSD and try powering it…

Regards,

I have flashed above image successfully, BBB turned Off automatically. Then removed SD card from socket and powered On BBB. Power indicator is turned On but User LED’s are not turning On in any pattern. I waited for long time but nothing is happening. Unfortunately I am not able to attach serial logs here. Getting new user can post only 2 links issue.