BBB - Serial port connected but terminal is empty

Hello guys,

First of all, I’m new using the BBB, so it’s possible I’m just doing something silly.

I’m trying to make a serial connection using PL2303, it seems to be a pretty straightforward process but for some reason it’s not working.

One of the tutorials I was following is this one: How to Set Up Minicom To Be Used with the BeagleBone Board in Ubuntu Linux

The problem:

I checked the pins connection and they are fine, the serial cable is identified by my computer too, so no problem here. I’m using Windows on my host machine, and connecting to the serial port using Putty with Speed 115200.


The connection works fine, but the terminal stays empty


I was expecting that the boot log would be outputed on the terminal, but nothing is happening. For context, I was trying to trigger the u-boot img on SD card, but I also tried to just boot BBB with the SO on eMMC but no terminal logs either.

Am I doing something wrong?

On windows, i recommend users use Tera Term project… Tera Term Open Source Project

One of the key differences, it does clearly state what interface/etc is tied to COM9… instead of just saying COM9…


Usually if you get no serial output (assuming you are using the correct COM port) it is because you have wired the connections up wrongly.

You should be wiring up Tx on one interface to Rx on the other. and vice versa. So often I see people thinking that these are just labels and that like labels are connected together. This is not the case.

Pretty nice tool, thanks for pointing out! :slight_smile:
On windows and COM ports I otherwise use RealTerm:

@sw3luke To check if connection from terminal to serial works, simply short Rx and Tx pin (without connected BB of course). Then when you send something to terminal, it must return immediately.

First of all, thanks for all the replies.

After change the cable to connection worked :sweat_smile:.

Thank you guys.