BBB SSH issues, Please Help

Hello, I’m having trouble using SSH to connect to my BBB.

I just got it for a school project, and was trying to set it up to connect with my Mac OS X. So I followed the getting started steps and everything worked great. Installed the 2 drivers and used the ssh root@ and installed googles Go. Also Added a few path variables to the bottom of the bashrc file. Everything worked, and tested the basic helloworld.go program, which ran. I wanted to disconnect everything and reconnect to be sure once everything was off for awhile it still worked. So I unplugged the USB cable to the BBB and then replugged it in. However the ssh command just hangs (also tried to connect via web browser but no good). I then tried to reinstall the drivers, and it worked. Ran the helloworld.go program, and it was still good. So I disconnected more safely this time. I ejected the drive from the Desktop, and then unplugged the usb cable. Replugged the USB cable, but the ssh command would hang again. I tried repeating the reinstall the drives (multiple times) method but it didn’t work this time. I’ve tried pressing the BBB onboard reset button and the on/off button but I can’t seem to get the SSH command to not hang. Please help! thank you (sorry if this is a repost but I couldn’t find anything relevant).