BBB ubuntu chronodot

Using Beaglebone Black(BBB)Rev C, Chronodot(ds3231) rtc via i2c, and Ubuntu 14.04 armhf 4.4.0-armv7-x2 (Robert Nelson’s armhf site).

I can get i2c recognition by BBB at 0x68 as expected with i2cdetect. Registration seems to work using echo to new device on i2c-2, since it comes up with a cat command. I can set hwclock and check with cat /sys/class/rtc/rtc1 file and all seems fine, until I do a cold reboot. Then everything reverts to Jan 15 01:01:00 2016. I am booting from an SD disk instead of onboard.

With regard to rtc, a check on dmesg gives me a reversion back to the rtc0 ,

“[ 3.748545] omap_rtc 44e3e000.rtc: rtc core: registered 44e3e000.rtc as rtc0”


“[ 3.867388] PM: bootloader does not support rtc-only!”

[ 4.220591] omap_rtc 44e3e000.rtc: setting system clock to 2000-01-01 00:00:01 UTC (946684801)

Here you can see my manual entries:

[ 2481.604507] rtc-ds1307 2-0068: SET TIME!

[ 2481.608512] rtc-ds1307 2-0068: rtc core: registered ds3231 as rtc1

[ 2481.608866] i2c i2c-2: new_device: Instantiated device ds3231 at 0x68

My questions : Why or how does the rtc instance get written over at boot?

Could this be a bootloader issue?

Is it a driver issue with Ubuntu non-support(states same as ds1307)?

I2c issue?

Or will the Chronodot simply not work with BBB and Ubuntu?

Note: Skill set- advanced newbie; not fresh newbie, but too hacking dangerous to ever be an expert!
Thank you in advance for any insight that you may have.


I hit this sometime back with Debian moving to systemd. I haven’t a clue if Ubuntu images are using systemd or not. If so “unless changed” systemd only supports rtc0. The answer I received from systemd mailing list was set the clock from userspace not kernel space. I disagree, yet pretty much got nowhere with that debate. Really not an answer, maybe a bit of help… Mike