BBB Ubuntu - No GUI on startup - known good board and monitor

Hello all,

I have a Beagle Bone Black that works out of the box with a new HP 22BW monitor. I am trying to run the 13.10 Ubuntu image from

I can load it onto the sd card and boot it. I get the penguin graphic and then the video goes away. I can still ssh into the BBB and I can see that it is running. I have installed gdm, etc onto the board but still no GUI. I don’t think it is a hardware problem, I think it is a configuration problem. I just don’t know where the GUI is supposed to be started from. Can anyone give me some guidance?


John Babrick

For sanity sake, can you please re-test with 13.04... The
xorg/mir/gdm/etc stack is still in a weird shape on 13.10...


ps, with 13.04 the


script is the only windows manager i've validated in the lab..


I started with 13.04, no joy.

I am ssh’ed into the board right now and it is running. I did an apt-get install ubuntu-desktop which appears to have succeeded. I can do a ps aux and see that a number of GUI processes seem to be running.

Also, the gui for ANgstrom comes up just fine from image found in eMMC…

Can you tell me where or how the GUI is invoked by the booting process?

upstart -> lightdm -> xorg -> gnome...

To repeat: If you want a working gui, from a fresh install run:

To setup, xorg/slim/modesetting/lxde such that it boots to a windows

For anything else patches welcome.

Otherwise it's kinda hard to directly compare gnome 2.32 on the eMMC
with ubuntu's version of gnome 3.8 / unity....


OK, I have re-installed 13.04 onto the sdcard according to the instructions found on (I checked the md5sum) and have the console prompt displaying on the HDMI monitor. I am logging in. I am at the ubuntu@arm:~$ prompt. I did the sudo ifconfig -a then the sudo dhclient eth0 .

I then did the /bin/sh /boot/uboot/tools/ubuntu/ . A large number of packages were downloaded and installed. 62.2 MB to be precise.

getting a warning message about “grep /boot/config-3.11.1-arm7-x14 no such file or directory” more than once followed update-initramfs…

getting a warning about being unable to autolaunch dbus-daemon without a $DISPLAY for X11

the script completes with ‘/tmp/xorg.conf’ => ‘/etc/X11/xorg.conf’
Please Reboot

and so I shall reboot…

penguin shows up, disappears…

flash of text at the top of the screen and the monitor goes to sleep. LEDs are flashing away. I shall wait…

OK, so I rebooted… no gui appeared. The lights are flashing… am I waiting for the image to be decompressed or something or can I run that script?

/boot/uboot/tools/ubuntu/small-lxde-desktop.shNope, I have tried it four different times. No joy. Cannot get anything to show up on the screen after rebooting after running the /boot/uboot/tools/ubuntu/ command. Dead in the water here.

OK< I’ve tried this every which way I can. all osrts of stuff gets loaded onto the BBB but no display appears. I am moving on to Angstrom…