BBB uses up 1 to 2 MB "disk" space per day

My BBB with the default Angstrom image (3.8.13, 2013 MAY 20) seems to use up 1 or 2 MB per day on rootfs sitting idle.

On a reboot the space frees up.

Anybody know where they space goes? I assume some log(s) somewhere are getting bigger?

I’m not worried about the space but I do wondering about any and all wear on the eMMC.

Most or all of the logs should be under /var/logs - have you looked there?

Will

I had looked there, but I didn’t look deep enough.

The used space is in /var/log/journal/ea1f552defe0435eb9540691e9ad30bd/
There’s a bunch of large log files in there. Looks like perhaps one for every time I’ve booted.
They aren’t plain text so I don’t know what’s in them.

Bill

I discovered journalctl pgm that can view those log files.

The logs are full of lines like this:

Jul 16 09:34:54 beaglebone bonescript[642]: - - - [Tue, 16 Jul 2013 13:34:54 GMT] “GET / HTTP/1.0” 2… “-”

One about every 40 seconds.

I am not sure this is how your system is set up, but on an ubuntu
system you can just move those logs to ram. Here are some notes from
the linuxcnc "set up linuxcnc on a cf card" page. I assume the system
is similar on the bbb. Someone can correct me if I'm wrong.

edit /etc/fstab

In fstab you should see a line something like this:

UUID=8037fd09-ea0d-4c28-a348-1fbdf9fb0b92 / ext3 relatime,errors=remount-ro 0 1

Add the noatime option. Normally every time you read a file, the time
is written back to the drive. The noatime option disables this.

UUID=8037fd09-ea0d-4c28-a348-1fbdf9fb0b92 / ext3
relatime,noatime,errors=remount-ro 0 1

Now add the following lines. They move most temporary files to a ram disk.

tmpfs /tmp tmpfs defaults,noatime 0 0

tmpfs /var/run tmpfs defaults,noatime 0 0

tmpfs /var/log tmpfs defaults,noatime 0 0

tmpfs /var/lock tmpfs defaults,noatime 0 0

tmpfs /var/tmp tmpfs defaults,noatime 0 0

tmpfs /var/lib/dhcp3 tmpfs defaults,noatime 0 0

Angstrom uses systemd. In /etc/journald.conf there are settings that allow complete control over the log sizes and where they are put (RAM or persistent storage):

http://www.freedesktop.org/software/systemd/man/journald.conf.html

HTH,

Dave.

I just did some stuff I found in this post: https://bbs.archlinux.org/viewtopic.php?id=150052

vi /etc/systemd/journald.conf

[Journal]
SystemMaxUse=20M
ForwardToSyslog=no

systemctl stop systemd-journald

mv /var/log/journal /var/log/journal.bak

mkdir /var/log/journal

systemctl start systemd-journald

We’ll see what happens in a few days of uptime.

I also turned of Bonescript:

systemctl disable bonescript.socket
systemctl disable bonescript.service
systemctl disable bonescript-autorun.service
systemctl stop bonescript.socket
systemctl stop bonescript.service
systemctl stop bonescript-autorun.service

Bill

Removing those old logs freed up over 300MB.