BBB with Micro SD for storage wont allow boot

I am using Angstrom and I am having an issue using a microSD card for storage. It was working fine with the directions outlined here. I was using the SD card to transfer wxGTK and wxPython to the BBB using the instructions outlined here. I installed wxGTK fine but got many warnings about space, I moved the files to the desktop because of permission errors. I got down to 0 bytes at one point, I wish the BBB had more storage.

After I installed wxGTK the Circuit co. method of using the microSD for extra storage no longer works. the BBB will try to boot but hangs on the initial loading screen. The ‘pwr’ led will remain lit and ‘user LED 1’ will blink as it normally does, ‘led 2’ will blink softly for a bit but the BBB will not boot. Any thoughts?

I have been formatting the SD card with a Mac OSX computer, like I said it was working before the install of wxGTK. I don’t see how install a library could affect the booting or not of an SD card. It has to be related in some way as this is the second time this has happened.

Again, any ideas would be helpful.


make a file named uEnv.txt on the SD card and add this to it:

mmcroot=/dev/mmcblk1p2 ro

Like I said, I’ve tried that and it worked great. BUT now something has changed and that no longer works. My original post outlines the specifics. I am just checking to see if anyone has a similar problem.

OK so short of you getting, and using a serial debug cable, along with examining the output of the debug terminal at boot. I do not know how we can tell what is happening.

Does anyone have a way to check the boot record from terminal through the USB?

What information do you need ?

fdisk -l (lower case L ) ?