BBB won't boot up (PWR Led does a single quick blink)

My BBB (A5A) was working fine with ARM Arch (installed on the eMMC), but since yesterday it won’t turn on. I don’t know what changed.

When I plug the power source or the USB cable the PWR Led quickly blinks, but the board doesn’t turn on.
If I press the POWER button, the PWR led does a single blink too, but it doesn’t proceed to boot.

I also tried to boot from the SD card, but It didn’t work.

Request an RMA.

And read this.


I am in the same situation. Was trying out new images. Did an forced SD change to a non-bootable bbb. Now it won’t boot. Just a pwr blink then dead.

Are there any other ways to recover other than RMA? PMIC replacement or reflashing of bootloader?


RMA is the only way.

I suggest you request an RMA.



There should be a short on board. The U2 shuts itself down to prevent the high current draw which is caused by the short. That is why the LED goes off after it blinks once.



I Also have exactly same behavior with my Rev C BBB.

@Gerald: I tried RMA twice but i did not got any response !! I got the Board from Sumeet Online shop which is listed on for Indian buyers. Any thoughts?

Thanks & Regards

Try the RMA again.


Many Thanks Gerald, I got response to my RMA request this time. In fact I received response to all my earlier RMA request as well.