BBB won't boot

Today I’ve flashed my BBB rev B with Debian 7.5 (went quicker than the described 45 minutes). After playing with the network settings I wanted to reboot “shutdown -r now”, when I did that the BBB did not came up anymore… Only the power led is on, other USR leds are not on, whatever I try (holding boot, power button, reset button, …).

After a while I connected the Serial Debug cable and I’m seeing the following message.
.\�(kR֨�[X��(V,�#�Y.�,.H�YX�Z�,�Z[X��SI��,�Y�k R�&.HK�KLC���$HQ��CR ### Please RESET the bcard ###
C�UK��,�TS��014.04-00014-c43880f5 (Apr 22 2014 - 132354)
�YX�Z�,�X���C�.[(kR֨�[X��(V,ר�.#HY��cr readinc imace arcs, err - -1
readinc 5-bcc4.imc
.\�(kV֨�[X��(V,�#�Y.�,.H�YX�Z�,�Z[X��SI��,�Y�k R�&.HK�KLC���$HQ��CR ### Plea3e RESET 4he bcard ###
TS��014.04-00014-c43880f5 (Apr 22 2014 - 132354)
�YX�Z�,�X���C�.\�(kR֨�[X��(V,Ө�&#HY��cr readinc imace arcs, err - -1
readinc 5-bcc4.imc
.\�(kR֨�[X��(V,�#�Y.�,.H�YX�Z�,�Z[X��SI��,�Y�k R�&.HK�KLC���$HQ��CR ### Plea3e RESET the bcard ###
C�UK��,�*TS��014.04-00014-c43880f5 (Apr 22 2014 - 132354)
�YX�Z�,�X���C�.\�(kV֨�[X��(V,Ө�&#HY��cr readinc imace arc3, err - -1
readinc 5-bcc4.imc
.\�(kR֨�[X��(V,�#�Y.�,.H�YX�Z�,�Z[X��SI��,�R�k R�&.HK�KLC���$HQ��CR ### Plea3e RESET the bcard ###

Only when pressing the RESET button I’m receiving feedback, however the same as above.

Googling did not bring me to any relevant topics so I tried the following without luck

  • Boot from SD
  • Re-flash emmc
  • power over USB or 5VDC
    Would be good to see if anyone else saw this before and/or has a solution to this.


Hi Micheal.

I have not experienced this exact problem myself but have experienced similar problems ( single power led lit only ). DO you know which kernel version that flasher image is using ?

I suspect this may be EEPROM related but short of that have you tried flashing an earlier version ? I’m personally using . .

$ cat /proc/sys/kernel/osrelease

on an A5A Beaglebone black, and it works fine. Also, what does the file / partition structure look like on the sdcard ?

The first ( FAT ) partition should have . . .

root@arm:/boot# ls -a
. … uEnv.txt uboot
root@arm:/boot# cd uboot/
root@arm:/boot/uboot# ls -a
. … MLO dtbs u-boot.img uEnv.txt zImage
root@arm:/boot/uboot# cd dtbs/
root@arm:/boot/uboot/dtbs# ls -a
. am335x-boneblack.dtb am335x-tester.dtb omap3-beagle.dtb omap4-panda-a4.dtb omap4-sdp.dtb
… am335x-evm.dtb omap2420-h4.dtb omap3-evm.dtb omap4-panda-es.dtb omap4-var-som.dtb
am335x-bone.dtb am335x-evmsk.dtb omap3-beagle-xm.dtb omap3-tobi.dtb omap4-panda.dtb omap5-evm.dtb Should not exist on your sdcard( I run a modified boot setup ).

Also for refference.

root@arm:/# lsblk
mmcblk1boot0 179:16 0 1M 1 disk
mmcblk1boot1 179:24 0 1M 1 disk
mmcblk0 179:0 0 14.7G 0 disk
|-mmcblk0p1 179:1 0 48M 0 part /boot/uboot
-mmcblk0p2 179:2 0 14.6G 0 part* *mmcblk1 179:8 0 1.8G 0 disk* *|-mmcblk1p1 179:9 0 70.6M 0 part* *-mmcblk1p2 179:10 0 1.7G 0 part
root@arm:/# blkid
/dev/mmcblk0p1: SEC_TYPE=“msdos” LABEL=“boot” UUID=“0E8A-D5A6” TYPE=“vfat”
/dev/mmcblk0p2: LABEL=“rootfs” UUID=“abf43946-e917-4a00-a9b5-a93386d2d5ed” TYPE=“ext4”
/dev/mmcblk1p1: LABEL=“BEAGLEBONE” UUID=“5147-0BEE” TYPE=“vfat”
/dev/mmcblk1p2: LABEL=“Angstrom” UUID=“ded34392-3812-4b8d-ab38-342da9a4b0d8” TYPE=“ext4”

I still have the original ( well updated once ) Angstrom on the MMC. mmcblk0 is the sdcard.

Hi William -

Good news - with another SD card from a friend I was able to boot the BBB. So as you mentioned, there is possibly something off with my SD card. Will re-format and try again.
Thanks for the quick reply!



Well thats good to hear. For future reference if you need it. is Robert Nelson’s build from scratch instructions. Now I do realize you did not ask how to build uboot / kernel from source etc, but perhaps the file structure sections will give you an idea of how things should be placed.

So now it sounds more like a missing MLO or am335x-boneblack.dtb. Probably the latter, but Robert would know best.

Hi William -

Looks my issue was not the SD card but the Serial cable. It’s not booting in the following scenarios:

  • Both ends USB and Serial connected
  • Serial connected, USB disconnected (probably due the FTDI chip?)
    We’re set at this point.
    Thanks for pointing me out to Roberts’ instructions - will come handy if I want to go more advanced!