BBB - Yocto - Kirkstone - USB connection

Hello, I have question,

I have followed this guide How the Yocto Project Brings Linux to the BBB – Takeoff Technical
And build new image based on “kirkstone”.
core-image-full-cmdline

I use Ubuntu 18 KDE Plasma.
But $lsusb doesn’t return new devices
$ ifconfig -a doesnt show new network interfaces
However I use FTDI serial to USB convertor and the hardware serial is working.
So the image that I have build is working but I don’t have usb connection.

Is the image that I use correct,I don’t see nothing in $ lsusb?
How can I make it work?

I followed this guide too Building BeagleBone Systems with Yocto, it is using poky-dunfell distribution.
But it is the same thing, when I’m building the yocto myself I don’t have the internet connection through USB.

Any ideas, do I need to set some parameter in local.conf or something?

Btw when building kirkstone, I’m not downloading
meta-openembeded and meta-beagleboard which are downloaded and added like layers here

Do I need some of these to make the USB/Ethernet connection works?

Or do I need to add thigns to the local.conf? For example:
IMAGE_INSTALL_APPEND = " openssh "

hasn’t been updated in 9 years…

Regards,

Solution!

The USB gadget hasn’t been enabled. I had to enable it.
To do this I created append recipe for the kernel - linux-yocto_5.15.bbappend which calls cfg file.
MY_CONFIG_FILE = “${TOPDIR}/…/poky/meta-mms-bsp/recipes-kernel/linux”
SRC_URI += “file://${MY_CONFIG_FILE}/my_custom.cfg”

my_custom.cfg file contains
CONFIG_USB_ETH=y
CONFIG_USB_G_NCM=m
CONFIG_USB_MASS_STORAGE=y

Also I added tothe image recipe CORE_IMAGE_EXTRA_INSTALL += “usbinit”