BBBW will not run boot script properly

I have a working Linux beaglebone 4.4.68-ti-r110 #1 SMP Wed Jun 21 04:31:35 UTC 2017 armv7l GNU/Linux
that does not use connman (uses /etc/network/interfaces) and successfully executes a boot script in init.d on a BBB.
When I try the same on a BBBW where connman is the only boot option, the script will not execute correctly. Connman is OK since it preserves ifconfig settings
and I do want to switch to the BBBW for commercial reasons.

I ran the latest update. The BBB works with these settings in boot/uEnv.txt:

##BeagleBone Black: HDMI (Audio/Video) disabled:
##Example v4.1.x

If I use these settings in the BBBW it will not boot at all - it just bricks.

The problem centers on this line in the boot script:

sudo bash -c ‘echo 1 > /sys/class/pwm/pwmchip4/export’

which will run on the BBB but not on the BBBW, unless I run the script manually once I get a login. Won’t run in /etc/rc.local either.

An idea on what I’m doing wrong would be appreciated.

The boot script is among other things trying to use pin 8.13 for pwm.