Beagle Board Black does not boot when powered from 5V barrel ...

I ran into an interesting problem that I have yet to investigate further which is related to this.

Be sure to use a multimeter and check what the actual voltage is on the plug of your 5V AC/DC supply converter.

I left my primary supply at my office so I rummaged around here at home to find another. A D-Link ethernet switch had a nice 5V 1.2A supply. Bingo.

I plugged it in, the power LED flashed, and then nothing. Tried pressing the power button once or twice and it didn’t work, but I wasn’t very persistent.

Then I checked the voltage. 6.1V. Over 20% over-voltage. Checking the PMIC datasheet for the BBB, it’s not entirely clear what happens in over-voltage conditions. Absolute max ratings for the ‘AC’ pin (where the barrel connector connects to the PMIC) are 20V DC so the part isn’t going to get damaged by 6.1V. That’s good. But recommended max voltage is 5.8V.

Perhaps I did a poor job of searching the datasheet and there is some over-voltage discussion in there somewhere. But as of right now, I don’t know whether over-voltage on the DC barrel connector will create odd behavior or not - I just have anecdotal evidence that suggests that it might, thus prompting a recommendation to verify the output voltage of any DC supply used to make sure it’s in the recommended range of the PMIC datasheet. I think it’s 4.2-5.8V, but I can’t recall so you should read the datasheet - part is TI TPS65217C.


Hello Kleven,

I also had a look at the putput of my power supplmy and found out some oscillations on it when loaded with the Beagle Bone or not.
But it seems a normal behaviour for a regulated power supply.

However, I have not seen any overvolatge.

Anyway, thank you for your help.