beagle board rev B not giving output on terminal

Hi,
I have a Beagleboard rev B board, and its not showing any output on terminal.

I have tried minicom on linux(KUbuntu), Teraterm and hyperterminal on windows, but i am not able to get any data on screen.

I have tried that on 3 machines, have double checked the cables and the settings but the problem is same, no output. what should i do.

I suggest you read the System Reference Manual. There is a section that takes you step by step to make sure you have the correct ribbon cable and null modem cable.

http://beagleboard.org/hardware/design

If this all checks out, then you need to request an RMA. There was an issue on early Rev B boards where the level shifter would fail. This was fixed on Rev B6 and later boards.

Gerald

What I found was that ALL of my DB-9 / dual-row header ribbon cables
were not wired the right way.
They were all the common crimp-on DB-9 and crimp-on dual-row header.
You just can't get there from here.

Please see the following for a very clear description:
  http://www.pccables.com/07120.htm

What does NOT work is this one:
  http://support.intel.com/support/motherboards/desktop/d845pt/sb/cs-013224.htm

- dan

Correct. You cannot use the Intel version. You must use the Everex version. This is spelled out on the System Reference Manual.

Gerald

Himanshu,

There are some useful suggestions at the BeagleBoard FAQ:
http://elinux.org/BeagleBoardFAQ#Serial_connection_.231

Hope this helps,
John

thanx for your help all of you, i'll try out the suggestions from all
of you. hope i don't have to bother you guys again.