Beagle board revision C3 Boot up

Hi all,

  We are having a beagle board of revision C3.The spec revels that it
come up with X loader and boot loader u boot.
But when we simply connect to the hyper terminal with proper settings
what we are getting only is the X loader line

as.........

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)

why it is not showing the the loading of u boot …???
Do we need to get it boot from the MMC/SD.Yet we will not try
this .since it says that the board comes up with boot loader(u boot)

Can anyone help me please or correct me .

Thanks
Maphil Philip

There could be several reasons for this. It looks to me like the NAND in the board does not have the UBoot in it or that the environment variables have been modified in some way.

I suggest you go to http://code.google.com/p/beagleboard/wiki/BeagleboardRevCValidation and restore the factory settings and code as indicated in the instructions, including the reflashing of the NAND.

Gerald

thanks for the help .i will look on to the link u have provided

Hi ,

The exact condition i am facing is
I am new to the board The version of board is C3
I am listing the issues with it while booting:

If try to boot using AC power supply, then there is no prints on
console

If try to boot using USB power supply then it keeps on printing
'Texas Instruments X-loader ....' continuously. as i have given

When I tried with pressing USER button while bootup, then also few
U-boot prints followed by CRC error ...

           Loading u-boot.bin from nand

U-Boot 2009.01-dirty (Feb 19 2009 - 12:22:31)

I2C: ready
OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 Beagle board + LPDDR/NAND
DRAM: 256 MB
NAND: 256 MiB
*** Warning - bad CRC or NAND, using default environment

Then the console goes with the print
Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24) .........

Presently I don't tried with SD or MMC card since it is given that
the board itself comes with Xloader and U boot
Correct me please

Thanks,
Maphil philip

i got everything as the manual says

but the problem is tht i connect both the power adapter and usb
otg .....in this setting only i am getting the serial prompt properly

I am not sure that if this setting (connecting both the OTG and 5v
adapter )will harm the board or not .

Well, per the manual, it says you can plug in both cables at the same time. Plugging in the USB OTG cable and the DC supply will not damage the board.

It does not make sense that only connecting both will give you a proper boot. It should boot using either one unless you have issues with the voltage levels. It sounds to me like you may have a grounding issue with your DC supply and your entire setup. I would make sure that all components in the system are plugged into the same power strip to make sure the grounds are all connected together.

Gerald

Thanks
i also think the same way as ground issue

but now i am not able to get login

the prompt is waiting as

The Angstrom Distribution beagleboard ttyS2

Angstrom 2008.1-test-20090127 beagleboard ttyS2

beagleboard login:

i connected the usb keyboard to the center usb hub i have .I cant
type using the key board .The keyboard getting powered correctly .

is thr any other issue

Thanks
Maphil Philip

The host USB port on the Beagle is High Speed only. You cannot plug in LS/FS devices, such as keyboards and mice because they will not work. They must be connected through a HS USB HUB first.

Gerald

Hi,

       I connected the keyboard to the hub that have which is of
USB2.0, and the hub is powered by the usb port in the system
(CPU).The beagle board is also powered to the OTG port from the
hub.Now i am trying the beagle board booting through the hyper
terminal.

But in connecting keyboard in the hub ,cant type anything<root> to get
login.or unable to hit any key to ot interrupt the booting .

The USB EHCI port is not supported in UBoot. It is only supported after the Linux kernel is loaded. You can only use the terminal on the serial port to interrupt the boot process. If it is working, then you should eb able to use the keyboard to login to Linux.

I am confused as to how the HUB is configured in the system. If it is powered by the Beagle, then you can’t power the Beagle via the OTG from the hub. You will have no power.

If the OTG goes to a PC and the hub connects to the Beagle and the keyboard is connected to the HUB, then that will work.

Gerald