Beagle Board USB Issues

Dear Sir/Madam,

I bought my beagle board around 1 month ago.
Unfortunately, I tried several kinds/types mouse/keyboard/USB hub but there is no response and can not control or input anything.

Does this occur to anyone?


Which board do you have?
What image are you running?
What keyboard and mouse have you tried?

I ahve not found a keyboard nor mice that would not run under linux, but there may be some.

Hi Ryan,

I have the same problem. I have keyboard, mouse etc connected via a high speed usb hub to my Beagleboard OMAP 3530 Rev C3 board but they all never get enumerated.

I have reported at the TI’s website and awaiting a reply.

One suggestion they made was to check the CONFIG parameters in the kernel.

If you are using the EHCI USB, check if the right config parameters are in place.


BeagleBoard does NOT support FS or LS devices. You must use a HUB to support those devices. Please refer the the System reference Manual for more information. These devices work fine on the BeagleBoard-xM.