Beagle Board XM, serial port, minicom, Linux: garbage on serial port

I'm copying much of this from a thread of about a year ago, because it seems pretty similar. Unfortunately that thread was not resolved.


  * Very recently-arrived BB XM I presume Rev C
  * Stock uSD card as delivered in box
  * DB9 serial port connected to USB/serial converter
  * minicom, set parameters to proper port, 115200, 8N1, no flow control

The result is stuff like this:

**???K???b? ?


Your PC or the USB to serial adapter may not be providing a good ground to the board. I have seen this before. Make sure that the PC and the 5V power supply are connected to the same power strip and that is it grounded to provide a good reference.


In message

Thanks Gerald and Dave for your suggestions.

Gerald: Do you mean a ground connection in addition to that provided by the serial port?

I'm using an FTDI breakout board from SparkFun, and I have a ground wire running from the bbmx pin 5 to the ground pin on the breakout board. (The only other wires are pins 2 and 3.) This is connected to my laptop via a USB cable, presumably with ground.

I have no power ground because the bbmx is powered by a BeagleJuice battery. All of my power supplies are double insulated, as Dave suggested, as is my laptop supply.

What I did do is connect another usb cable to my computer, and then hold the shell of the other end against the metal shell of the connectors on the bbmx. Assuming all metal shells are grounded, this should have solved that problem.

No difference.

I also tried another serial adapter; this one a Prolific cable. Same thing.

I'm busy rebuilding my sd card right now (downloading Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 is time consuming!) and will report on that.

Meanwhile, further information:

On reset, the two green LEDs next to the uSD card (USR0 and USR1) go out. THey both come on after about a second.

After about 10 seconds they both go out briefly, then they have a burst of activity, and then USR1 stays on while USR0 does a beat of either 2 or 3 flashes.

Every so often USR1 gets a burst of activity, and this seems to correspond to a burst of garbage on minicom.

Does this suggest anything?

I suggest as you have all these variables, which you never mentioned in your ealier post, that you back up. Dump the BeagleJuice for now. Just work with the BeagleBoard. Make sure it is OK
by connecting it to a DC supply and connect it to a DC powered Laptop. Then add the other components one at a time and see where it fails.


I must have read your mind, because that's exactly what I did since our last email.

A nice stable power supply, 5V at 2.4A.

Exactly the same behavior.

Does the pattern of activity on USR0 and USR1 suggest anything to you?

Try recreating the SD card.



yep, doing that right now. still downloading the image.

picked up a few 4G uSD cards on my way in to work, expecting that this is the most likely cause.


In case anyone else has this problem, my solution might help:

I pulled out my magnifying binoculars to look closely at the fingers on the SD card socket. That was OK, but while I was looking, I spotted a cold solder joint on my DB9 adapter.

Not the one on the BBxM, but the mating one I made in haste and excitement.....

Thanks everyone for your help.