Beagle bone black, difficulty getting started

I have a second hand BBB and it seems to be setup with bespoke image. I can boot it from the SD card I made on the BB website, but am not able to get the image copied over to the BBB. I have looked on the net and tried a few things (they did not work) that I really don’t understand and am looking for someone to advise me in a little more of an explanatory way please?

What I have achieved. Made an SD card with a BBB image. Inserted card, booted with the button held down and released. Logged in as debian using putty with SSH.

What I have not achieved. Tried to boot without an SD card and can not see BBB using arp -a in command line.

Do you know the version of BeagleBone Black you have?

If you use a Flasher image it should write to the on board eMMC but you would need to know which BBB you have.

Also, you can write to the eMMC from a standard image by editing the /boot/uEnv.tx file.



Thx for reply. I think it is a Rev C. it is a AM3358BZCZ100 processor and it says 4G on the EMMC chip.

I believe that the image on the beaglebone website is not a flasher.

I Login as debian (password = temppwd) and type sudo nano /boot/uEnv.txt and get a blank black screen with a grey line at the top as per pic. There is nothing there to edit.


I have a second hand BBB and it seems to be setup with bespoke image. I

  If it is old enough to be a 2GB eMMC you may find it a problem. That
series shipped with Angstrom as the OS, which hasn't been used in ages.

  The Debian IoT image requires a 4GB eMMC to install. There IS a Debian
Console image that may fit in 2GB -- but as the name implies, it is a very
minimal feature set (LXQT images have X-Window desktops, IoT have lots of
stuff except the desktop; I'd hope Console has networking at least <G>).

What I have achieved. Made an SD card with a BBB image. Inserted card,
booted with the button held down and released. Logged in as debian using
putty with SSH.

  Note that if you successfully flash a recent Debian image to the eMMC,
you shouldn't need the boot select switch. The board will load u-boot from
eMMC, u-boot will detect an inserted SD card and load device trees and
kernel image from the SD card, and make the SD card the primary file

I am sure it has 4G eMMC as it says so on the chip.

I does not boot without the SD inserted. It does boot form the SD card. I do not seem to be able to edit the SD card.

When I try to edit the SD card I find that it does not have anything on it?

If it is booting from the eMMC does it need an SD card to be inserted? Could it be that the SD is not containing anything but is somehow helping it boot?

It definitely only boots with the SD card in and the boot switch depressed. It does not boot if the switch is not depressed.

can one edit the SD when plugged in a PC somehow?

From your screen shot, you opened "/boot/uEnv#.txt"... Which is
mis-spelled, open: /boot/uEnv.txt


If you mount the SD card on a LINUX file system... (which is what
happens when you successfully boot a Beagle with the card!)

  Windows has no idea what an ext4 file system is, and considers the card
to be unformatted.

Thank you for the replies. Much appreciated. I have corrected my error and this is the screen. I do not see any eMMC Flasher command to change here? is it the eMMC cape disable I need to edit? Sorry an a true amateur! What next?
Screenshot 2021-01-19 171417.png

It's at the bottom, last line..


It should be at the bottom/end of the file.


Screenshot 2021-01-19 171417.png

Note, if you go this route, you will still need to mount the uSD card and uncomment the flasher line. You could use a VirtualBox Linux image on Windows 10 with a uSD to USB reader, or if you have a SD card reader on the PC, and assign the USB device to the VM. You should be able to edit the file from there.

The other option is to just reflash the uSD card.

Just don’t let Windows format the uSD card.


Screenshot 2021-01-19 171417.png

Amazing. Thanks all. I think I did it. Lots f exciting light displays on the BBB and putty went wild with all sorts going on.

The flasher is more bellow:

In a line like:

##enable x15: eMMC Flasher:
##make sure, these tools are installed: dosfstools rsync

Screenshot 2021-01-19 171417.png

ONE: WHY did you use a screen image capture... It is a text console,
just select and paste the text!

  TWO: your image only seems to show the top of the file. uEnv.txt is
much longer than your screen. The line to convert to a flasher is at the
very end of the file.

When it reprograms the emmc, your user LEDs will begin flashing in a cylon/night rider pattern. Wait until that stops. Then temove your card and comment out that last line in uEnv.txt file.

I have seen issues editing a uEnv.txt in Windows. When you save the file, it converts the files format and UBOOT will not read it. Your boot up will freeze.
And in ubuntu, uEnv.txt may show up as read only in the text editor. Open a terminal in the boot directory and use $sudo vim uEnv.txt or $sudo nano uEnv.txt to edit the file.

Raymond Willis Jr.

Thank you for this.

from Paul

Use your down arrow. To scroll to the bottom of the file. Nano does not display every line of the file.

Raymond Willis Jr.

Screenshot 2021-01-19 171417.png

Thank you.

from Paul

Screenshot 2021-01-19 171417.png

Screenshot 2021-01-19 171417.png