Beagle Bone Black Newbie

Hi all , good day
I just got my BeagleBone Black and Im operating it on windows. I have issue on flashing the eMMC. I tried multiple times but i end up getting both my sd card damaged. Unlike others who i consulted they have solution but by running through some programs to identify the problem and most of the uses Linux. I cant really solve my issue and i need some guidance before i could proceed.

  1. I could get the board to booting process but at the end , when i check my debian-image , it’s still the same as the image at intial.

  2. I tried to configure the Board through Cloud IDE and its also a failure even after connecting to Internet.

  3. Im using Putty to access Ubuntu and the system keep spamming me “Security Breach” , i could barely do anything,

I need your help

I had success using Balena etcher and the image(s) referenced in the upgrade instructions on the general website. And yeah, the microSD card, once it is flashed isn’t readable by Windows. It don’t recognize the filesystem format.

If you want to see if the card is really damaged, you can boot up the BBB before inserting the SD card, then manually mount it, and take a look at it.

“lsblk” will tell you if it actually sees the card and its partition. They’ll be mmcblk0 and mmcblk0p1

Mounting requires you to be working as root, so
“sudo mount /dev/mmcblk0p1 /media” will hook up the partition so the card’s root directory sits at the /media folder.

Thank you sir , I will work on it. Much appreciated