Beagle bone ssh

I am able to connect to the built in web server with my BeagleBone Revision A4 through USB, but when I connect the bone to my router and plug it in through ethernet, I try to ssh into it using “ssh root@beaglebone.local” and it returns something like “ssh: Could not resolve hostname beaglebone.local: nodename nor servname provided, or not known” I have researched this thoroughly and could not find anything. Please keep in mind that I am a 6th grader, however I have a lot of experience in Unix terminals and C based programming languages.

PS: Do I have to choose between Newbie or Expert for the skill level category? :smiley:

Which BeagleBone board do you have? There are two different boards. One white and one black.


i have a the white one.

Just wanted to make sure. There were a few Rev A4 BBB that went out.


The name 'beaglebone.local' has to be resolved by the DNS system used
by the computer you're connecting from.
Whether this works depends on the details of your internal network
setup and the settings of the software on your BB.
Try ssh root@ as this seems to be the default IP address
used by Angstrom on BB. If that doesn't work,
I would dump the network traffic using something like wireshark to see
what your BB is doing when it boots.

Hi, I already tried the IP address a long time ago. As for the wireshark thing, I will look into it, also one more thing you might wanna know... I am able to ssh into the beaglebone with a USB cable and an Ethernet cable both connected to the computer (Mid 2011 iMac dual booted to run Ubuntu), however get a connection timeout when the bone is connected to the router. And yes, I used the ip instead of "beaglebone.local".

So here's the plan:
- make sure your BBB booted successfully: are the four blue LEDs
blinking as expected?
- find what IP is the BBB on
- find if SSH service is ready to use, e.g. by doing nmap
  on my system the result is:

22/tcp open ssh
80/tcp open http
443/tcp open https
3000/tcp open ppp

Caden Farley have a White BeagleBone not a Black one.

This mean that the address doesn’t work as it’s the IP address for the virtual Ethernet on USB.

The router give another address to the BeagleBone. Personally I could connect to the router with a web interface and know the ip address of the connected computers.
In you case you could connect to the BB with the USBTTy and read the IP address with ifconfig command.

you have to unmount your beagle bone mass storage device at first
Next reboot your beagle bone

use screen for the same
using ipconfig find out eth0 and
then you can go for ssh root@IP OF BONE

Ok, so earlier I used a tool called connman to change the IP address to and tried to ssh into the bone, and it returned: "connection to root@ port 22: No route to host" at least it recognizes the bone but I'm not sure what that means. I was connected through wifi (on the same router) on the client computer.
So the boot sequence carried out successfully(4 green LEDs blinking), the ip is, and executing "nmap" returns something like "the host seems to be down." After a little while. And thanks Rituparna, but I have my bone connected to the router, so ther is no USB mass storage. Don't only older versions of Ängström require unmounting? I updated to the latest image.(before I did, I couldn't even get the built in web server running) I will try to ssh into my bone through USB to double check that the ip right. One note: is the ip by default static or dynamic and if it is dynamic, how do I set it to be static?


I will tell how I use to connect to my Beaglebone

  1. screen /dev/ttyUSB0 115200

  2. Loog in

  3. eject BEAGLE_BONE

  4. ifconfig to get the beaglebone ip. I got

  5. after that
    rituparna@rituparna-desktop:~$ ssh root@
    root@’s password:

I think it will help you

regarding the static ip and all you will get enough information in google search



when I log in serially, it said, “Sorry, could not find a PTY [screen terminating]”
i tried to ssh through USB and it worked fine.
When I type ifconfig I see all the adapters have ip addresses except for eth0, which had no ip.
I found through Connman that I had changed the ip address of USB (wait what? USB has an ip??) and eth0 had no ip. her is what connman returned when I typed ./get-services

caden@caden-iMac:~$ ssh root@beaglebone.local
root@beaglebone.local’s password:
root@beaglebone:~# cd /usr/lib/connman/test
root@beaglebone:/usr/lib/connman/test# ./get-services
[ /net/connman/service/ethernet_d494a1539daa_cable ]
IPv6.Configuration = { Method=manual Privacy=disabled }
AutoConnect = true
Name = Wired
Nameservers = [ ]
Provider = { }
Favorite = true
Domains.Configuration = [ ]
Timeservers.Configuration = dbus.Array([], signature=dbus.Signature(‘s’), variant_level=1)
State = ready
Proxy = { Method=direct }
Nameservers.Configuration = [ ]
IPv4 = { Netmask= Method=manual Address= }
Timeservers = dbus.Array([dbus.String(u’’), dbus.String(u’’), dbus.String(u’’), dbus.String(u’’), dbus.String(u’’)], signature=dbus.Signature(‘s’), variant_level=1)
IPv6 = { Method=manual Privacy=disabled }
Domains = [ ]
Ethernet = { Interface=eth0 MTU=1500 Method=auto Address=D4:94:A1:53:9D:AA }
Security = [ ]
Proxy.Configuration = { }
Type = ethernet
Immutable = false
IPv4.Configuration = { Netmask= Gateway= Method=manual Address= }


where is says Ethernet = { Interface=eth0 MTU=1500 Method=auto Address=D4:94:A1:53:9D:AA } that is where I foumd out that the eth0 ip is still on auto, or a dynamic ip in other words.

I also googled how to assign a static ip and the one tutorial that showed up didnt work and probably got me even further into trouble.

you must unmount the BEAGLE_BONE otherwise eth0 will not run


Connect the beaglebone to your PC and

Follow the bellow mention steps and fill the ?? marks with the result you got

  1. dmesg | grep FTDI | grep “now attached to” | tail -n1 | awk ‘{print $NF}’


  1. I will tell in the next mail