beagleboard and devkit 8000


I have devkit 8000 board.

As it uses same OMAP3 platform, and pheripherals are mostly the same, except ethernet is brought into the board and few other things like keypad interface and mic biasing in the board.

Can i use the same android-2.6.29 kernel from embniux which i used for beagle board for this devkit 8000 to boot and work with basic usb keyboard, and s-video.

Thanks and Regards,

You should be able to use same sources, I am not sure about the pin
muxing in u-boot, it might need some changes - again just a guess I
have not seen the schematics for the same.

The ethernet driver that devkit has may not be part of our kernel
releases on beagle so far, you might have to port the same. Rest
should work as is.

Can you setup a wiki and share your experiences so far.




Thanks, i will use the default u-boot which is already loaded in the board.

I use the kernel and android file system from embinux.

The ethernet driver being used in devkit8000 is dm9000 and mostly same compared to android-2.6.29.

only the platform data changes for ethernet to be added in arch/arm/mach-omap2/omap3beagle.c

I also went through the source code of linux-2.6.28-omap came along with the devkit 8000 and android-2.6.29 for beagle from embinux, most of the things still the same.

minor variations in twl4030.c.
keypad,touchscreen,lcd panel support added.

I will load the andorid-2.6.29 kernel image to devkit 8000 and check all the pheripherals.

Thanks and Regards,

I wish people would feed their changes back to drivers, the dm9000 is one
of the drivers that I try and maintain (we use a variety of these devices
on our own boards). Do you have a set of diffs for the driver so that I
can see what has changed?

Same goes for angstrom customizations.


it looks strange,

the kernel src got from embest for devkit8000 is linux-2.6.28-omap1 and it has lot missing, so far i worked on beagle, i have all working components there.

the devkit 8000 kernel src does not have s-video and android support in it. they ship only the uImage which android chnages in it.

I tried to load uImage built from beagle config, i thought it will boot and depencides can be short later. unfortunatley, it does boot even.

this is the log, any pointers to help for this and make beagle kernel to work on devkit8000.

U-Boot 1.3.3-svn239 (Apr 17 2009 - 10:43:28)

OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 DevKit8000 Board + LPDDR/NAND
DRAM: 128 MB
NAND: 128 MiB
*** Warning - bad CRC or NAND, using default environment

In: serial
Out: serial
Err: serial
Hit any key to stop autoboot: 0
OMAP3 DevKit8000 # mmcinit
OMAP3 DevKit8000 # fatload mmc 0 0x80200000 kernel;bootm 0x80200000
reading kernel

2199532 bytes read

Booting kernel from Legacy Image at 80200000 …

Image Name: Linux-2.6.29-omap1-07193-g3f4964
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2199468 Bytes = 2.1 MB
Load Address: 80008000
Entry Point: 80008000
Verifying Checksum … OK
Loading Kernel Image … OK

Starting kernel …

Uncompressing Linux…

Thanks and Regards,

Thanks …

the machine number for devkit 8000 and beagle board was different, so it refused to boot.

then, after changing the machine number is arch/arm/tools/mach-types, the beagle kernel booted fine in devkit 8000.

Now, to check all the pheripherals like USB, MMC, audio in and out, ethernet and DSS.

Also, i have one doubt, this is some what, i disturbing the beagle number in beagle_config. I have seen in the same link, for any machine number, to boot without hanging. it speaks aboutt arch/arm/boot/compressed/head-omap.S.

what will be the starting function for beagle, if i have to put that in head-omap3.S like for example.

Thanks and Regards,

Hi all,

I found interest in this chat as I am using both devkit8000 and beagleboard.
While evaluating devkit8000 I have also found that many things are missing in devkit kernel.
More precisely I am concerned about frame buffer.
While running on beagle board I found it is possible to have multiple frame buffers with "vram= " argument in kernel command line.
But while in devkit if you specify this argument its DMA memory allocation fails. and it does not create any frame buffer device.
In absence of this argument by default devkit800 has only one fb device.
So anybody here who knows how to add multiple frame buffer devices to devkit8000?

Please let me know.

Thanks and regards,

Hi omkar,

i am using default kernel came with devkit 8000 board and found many were missing. so i am in the course of using android 2.6.29 from embinux on devkit. So for now, able to boot the android 2.6.29 kernel, ethernet driver is also added and working fine. getting the busybox prompt and able to run the android. Coming to ur question, the boot args i am using is this,

console=ttyS2,115200n8 noinitrd root=/dev/mmcblk0p2 omapdss.def_disp=tv omapfb.debug=y omapdss.debug=y omapfb.mode=“tv:ntsc” init=/init rootfstype=ext3 rw rootdelay=1 nohz=off

this works for me, i can see in the dmesg showing respective debugs. it creating 3 framebuffers and display manager is tv.

But, display unit i am using is TV and i do not have TV in my office now, so i cannot actually see the display, i am see only the dmesg output and proc entry as mentioned in DSS documentation.

Also, in addition to display, i have to test audio and usb interface.

u can find the bootargs, how to set the lcd or dvi in DSS documentation or from embinux porting to android with gstreamer integration wiki.;a=blob;f=Documentation/arm/OMAP/DSS;h=9e902a2c3c51ac47a6ab0ac7e236e928ac390f22;hb=refs/heads/android-omap-2.6.29;a=blob;f=drivers/video/modedb.c;h=16186240c5f22ba47b63971847ba6e2384515d27;hb=refs/heads/android-omap-2.6.29

Thanks and Regards,

The problem is not with bootargs …
It is to do with DSS2 driver support in kernel which I am missing in my devkit kernel.
It’s version is 2.6.28-omap1 and I think it’s missing this support.
So I want kernel which has this support.
Most probably i think it is in 2.6.29 with addition of some patches.
So can anybody let me know how shall I get this beagle board kernel and have this stuff working?
The kernel that I have checked out is latest one(through git) I want to fall back to this.

So pls let me know if anyone of U did this…

Thanks and regards,


android-2.6.29 has all these support. u can use the same kernel with minor modification to work in devkit as i told in my previous mail. u can see my previous mail to see what the stage now in. Also, u can test the few things.

Thanks and Regards,


DSS works on devkit 8000.

able to get beagleboard logo and andorid running on devkit 8000 with android 2.6.29 kernel.

the only issue is usb and mic-in not working.

Thanks and Regards,

Hi all,
I am using OE git, and OE kernel compiled with angstrom toolchain. Everything works fine for beagleboard. Kernel version is linux-omap-2.6.29-r35. I want to run same on devkit800. So checked this mailing list. What I found is I need to add devkit macros in arch/arm/tools/mach-types file. But here is some conflict. The kernel available with devkit(2.6.28) has different IDs and those are occupied by other machines in current mach-types file. I also checked on arm site and found that devkit has been assigned with different IDs.

So what can be the approach ?

  1. Changing u-Boot.
  2. Putting devkit details by erasing current details.

Also I tried adding devkit details but let me know is there any change required in omap3-beableboard.c ? (MACHINE_START Macro) ??

Thanks & Regards,