[beagleboard] Beagleboard can't connect wireless network

I have two usb wifi stick. 1 zydas zd1211 and other one is ralink rt73 chipset wifi. Whichever I plugged in beagle it recognize as wlan card but it says;

wlan0: link is not ready

and network is unreachable.

I tried to change /etc/network/interfaces file;

I added these lines;
auto wlan0
iface wlan0 inet dhcp
pre-up/sbin/iwconfig wlan0 essid beagle
pre-up/sbin/iwconfig wlan0 txpower on
/sbin/ifconfig waln0 up

with these settings my gumstix works well, but not my beagle?

where did I do sth wrong?

Did you check if the firmware was correctly loaded into the usb wlan device.

I have an airlink101 AWLL3025 USB wifi. It uses the zd1211 chip.
I installed it to my C4 beagleboard running angstrom demo. Once the angstrom
boot up, I click the lower right button on the desktop. The wifi will detect
anything available. Select your wifi and enter your password, you can
get connect at no time.

Good luck


I am currently using latest stable angstrom image, it recognize both wifi siticks but none of them works.

seems nothing wrong about wifi sticks and modules bcoz beagle does not state any error neither booting nor when I plugged wifi

I tried iwconfig wlan0 essid beagle
and ifconfig wlan0

it sets this values but it is unreachable from remote computers and also no internet access

2010/5/22 hedwin <hedwin.koning@gmail.com>

If you have a ralink rt73 chip there should be a file called rt73.bin (the firmware) in the /lib/firmware directory.
When you insmod the kernel driver it will load the firmware to your usb device.
The kernel log will tell you if this was succesful or not.

I have experienced similar problems. I use both the beagleboard and gumstix overo and wifi sticks with the chip sets that are mentioned.

I haven’t actually tried the rt73 device on the gumstix but had no problems with it on the beagleboard. As the previous poster mentioned, you need the rt73.bin in the firmware directory. I did this on a console image that I built using bitbake.

On the other hand I have had mixed success with the zd1211. The OE/bitbake system, when on the stable branch builds kernel version 2.6.29 I think - sorry if this is wrong, but I am not at my development machine. With this the stick is almost always recognised, but when looking at the boot messages, you may discover that the firmware does not always load properly. With this setup I usually get one proper boot in every 10 - usually on cold boot.

The gumstix however, I you followed the instructions on their site to setup your build environment (I cannot remember which branch), the 2.6.32 kernel builds. This always (touch wood) recognises the zd1211 stick and loads firmware and then follows the config in the interfaces file.

I got my beagleboard working with the zd1211 stick by using the online image builder. This provides the 2.6.32 kernel. I then installed the packages I needed.

Hopefully this helps.

boot message about firmware is :

[ 47.594299] rt73usb 2-2.4.2:1.0: firmware: requesting rt73.bin
[ 47.717071] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 51.398834] CMEMK module: built on Mar 18 2010 at 13:19:12

and I double checked the firmware directory, it is there.
my distro: Angstrom 2009.X-test-20100104

2010/5/23 Chithambaram Veerappan <dm6437uom@googlemail.com>

You mention not getting out on internet or in?
looks like your gateway is not set. it should be in /etc/resolv.conf

My problem is about getting in internet. I am trying out other images now.

Also I tried usb stick with my PC, UBUNTU 10.04 but no success. - But it works on windows, I am confused

2010/5/23 djlewis <djlewis@tcworks.net>

ifconfig output:
wlan0 Link encap:Ethernet HWaddr 00:0E:E8:D3:1B:8B
inet addr: Bcast: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
iwconfig output is:
wlan0 IEEE 802.11bg ESSID:“beagle”
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
but no internet

2010/5/23 djlewis <djlewis@tcworks.net>

  Hi, I read your log "Access Point: Not-Associated" and your
" ESSID:"beagle" ". Is Beagle the name of your WIFI router's
essid or the hostname of your BeagleBoard. If the latter, then
the essid should be set to the wifi routers declared essid.

BTW: I just tested:

And using the network manager I was able to easily setup both dhcp and
static ip operation of my usb wifi. One should be logged in as root to
do this.

Just checking,
Don Lewis
irc: djlewis

which kernel do you use? I am using 2.6.32 latest with no success.

2010/5/24 djlewis <djlewis@tcworks.net>

root@beagle:~# uname -a
Linux beagle 2.6.32 #1 PREEMPT Thu Apr 15 12:05:47 CEST 2010 armv7l

Don Lewis