[beagleboard] BeagleBoard-xM rev C - U-Boot hangs at NAND:

you first need to copy the mlo in the boot partition of the SD card.
As there is no NAND available on BB-xM, so our SD card has to perform the work of Boot partition and mlo starts it.


I agree there is no nand available, hence why it is puzzling me as to why the board just stops booting.

I have tried the original sd card I got with the board, which to the best of my knowledge has not changed as I only used it to do a first boot, after that I have always created new sd images from Robert C Nelsons pages, which have worked until now.

The MLO is present and must be doing something else U-Boot would not start.

U-Boot runs until it tries to print NAND on the terminal, so something after that is causing the board to crash.

So, what does the board do after checking for NAND?
It looks like it probes for expansion boards, but there are none fitted.

Any ideas or is it just a question of throwing the hardware in the bin.


I think it’s due to missing boot.src. have u created a boot.src and uEnv.txt for ur board…??
If no, than you should try them. These files worked fine in my case…330.gif