BeagleBoard Black rev c Memory and Browser

My “Htop” shows I have “482megs of ram total” is this correct ? Also it’s nearly impossible to use Firefox.
I have the “am335x-debian-11.7-xfce-armhf-2023-09-02-4gb” image installed on a Microsd card.
I have BeagleBoard connected to a 24 inch tv thru Hdmi. Are there any graphic settings I can use to improve performance?

That’s pretty normal today, a device such as the BBB, single core Cortex-A8 with only 512MB of ram, will not run Firefox/Chrome… At this point, those browsers are just too bloated…


I haven’t seen Firefox run on on the BBB using xfce either.
Well, that’s only partially true. I’d rather say I saw it crawl at an imperceptibly slow pace.

It didn’t fail to work. It just failed to complete what it was doing in a timely manner.

I did see it manage to load web page(s) onto the screen, but you’ve got enough time to go pour a cup of coffee between launch and it showing a home page. It literally took a good minute or two to put itself up.

I use chromium on a BBB. It’s not perfect, but it’s totally usable. Depends on the use case.

Kernel: 5.10.145-ti-r55

Chromium: 109.0.5414.74

Debian: 11.6

With these options

–disable-gpu --disable-gpu-rasterization --disable-zero-copy --disable-accelerated-video-decode --disable-webrtc-hw-vp8-encoding --disable-gpu-compositing

I will give your options a try.
Thank you for taking time to reply.