[beagleboard] cannot start script automatically


Excerpts from Francesco's message of 2012-06-27 10:07:55 +0200:

I then tried to add the script to /etc/init.d , ensured it is executable
tried update-rc myscript defaults
added a slink in rc3.d, rc4.d, rc5.d
At reboot it does not start (buuuu :frowning: )

angstrom does not use init.d, so that can't work. You shall use instead
a systemd service file. Take /lib/systemd/system/cloud9.service, copy it
to /lib/systemd/system/myservice.service and then do :

systemctl enable myservice.service
systemctl activate myservice.service
systemctl daemon-reload

and your service will be launched on restart.

systemctl --help or RTFM on your favorite search engine for more.

Tried to add it to crontab with crontab -e

verify :
root@beaglebone:~# crontab -l
30 * * * * /usr/bin/ntpdate -b -s -u pool.ntp.org
52 * * * * /home/root/mydir/runb.sh

and ps shows crond is running

I would expect it to run at minute 52 of every hour, every day etc, right?
Does not run :frowning:

What I'd do is to edit directly the /etc/crontab file to add
your command, as it is said on top of the /etc/crontab.

I am getting crazy with this thing, anyone can help?

hope that helps.