[beagleboard] How to make kernel-image.deb?

How can I make kernel-image.deb for
building rootfs by rootstock for my devkit8000?

Linux kernel source is from http://gitorious.org/devkit8000

Just likes the *.deb on http://rcn-ee.net/deb/

Because my board is devkit8000, not beagleboard,
I think it'll better than direct using the kernel-image.deb from
http://rcn-ee.net/deb/ for rootstock.

make deb-pkg

Regards,

OK, I got some err msg.
I think that source has no “deb-pkg” make target.

This syntax is correct..

What version of the kernel source are you using? (deb-pkg's first
introduced in 2.6.32)

otherwise you'll have to use the old make-kpkg

Regards,

I git from http://gitorious.org/devkit8000 by:
‘git clone git://gitorious.org/devkit8000/linux-omap-devkit8000.git

2010/5/3 Robert Nelson <robertcnelson@gmail.com>

What version of the kernel source are you using? (deb-pkg’s first
introduced in 2.6.32)

otherwise you’ll have to use the old make-kpkg

I’ll try it later.

I got kernel source from:
git clone git://gitorious.org/devkit8000/linux-omap-devkit8000.git
cd linux-omap-devkit8000

current kernel source version is: 2.6.35-rc3-g344c93e
(commit: 344c93e3487367a7003a1a16e64ce48fa8b662fa)

after…
$ ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-
$ make distclean
$ make ARCH=arm devkit8000_defconfig
$ fakeroot make-kpkg --arch arm --cross_compile=arm-none-linux-gnueabi- kernel_image
exec debian/rules DEBIAN_REVISION=2.6.35-rc3-g344c93e-10.00.Custom KPKG_ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- kernel_image
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
/usr/bin/make -f ./debian/rules debian/stamp/binary/pre-linux-image-2.6.35-rc3-g344c93e-dirty
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
dpkg-architecture: warning: Specified GNU system type arm-linux-gnu does not match gcc system type i486-linux-gnu.
make[1]: Entering directory /home/cvlsi/work/img-src/linux-omap-devkit8000' ====== making target debian/stamp/install/linux-image-2.6.35-rc3-g344c93e-dirty [new prereqs: ]====== This is kernel package version 11.015. echo "The UTS Release version in include/linux/version.h"; echo " \"\" "; echo "does not match current version:"; echo " \"2.6.35-rc3-g344c93e-dirty\" "; echo "Please correct this."; exit 2 The UTS Release version in include/linux/version.h "" does not match current version: "2.6.35-rc3-g344c93e-dirty" Please correct this. make[1]: *** [debian/stamp/install/linux-image-2.6.35-rc3-g344c93e-dirty] Error 2 make[1]: Leaving directory /home/cvlsi/work/img-src/linux-omap-devkit8000’
make: *** [kernel_image] Error 2

Don't waste your time with the external make-kpkg package...

use the kernel internal deb script "deb-pkg"

Regards,

$ ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-
$ make distclean
$ make ARCH=arm devkit8000_defconfig
$ make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- deb-pkg
scripts/kconfig/conf -s arch/arm/Kconfig
make[1]: *** No rule to make target `deb-pkg’. Stop.
make: *** [deb-pkg] Error 2

It seems that it didn’t have “deb-pkg” make target.
Fine, I give up and back to use the kernel.deb on the rcn-ee.net
for rootstock lucid rootfs for my Devkit8000.

2010/7/3 Robert Nelson <robertcnelson@gmail.com>

I don't think you understand..

Pre-2.6.32 deb-pkg doesn't exist...

In your last post your using 2.6.35-rc3+++

which has deb-pkg..

Regards,

After I changed from
git://gitorious.org/devkit8000/linux-omap-devkit8000.git to
git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git
, the kernel source generated .deb with same instructions above successfully!
(got “linux-kernel-2.6.35-rc3-08585-g01c0bca-dirty-1_armel.deb”),
so it’s linux-omap-devkit8000’s problem, ya?

The defconfig I used: “devkit8000_defconfig”.

BTW, I had used the .deb to build my own lucid rootfs by rootstock successfully,
(linux-omap-2.6 2.6.35-rc3-08585-g01c0bca-dirty)
but it got kernel panic as same as the latest linux-omap-devkit8000
(2.6.35-rc3-g344c93e) when booting,
since linux-omap-devkit8000 boots fine with previous version
before 2.6.34-rc6-g8ee7837-dirty (include 2.6.34-rc6-g8ee7837-dirty).

My goal is building a Ubuntu 10.04 (lucid) rootfs
with TI SGX driver enabled on my Devkit8000 baord.
Because according to
http://elinux.org/BeagleBoardUbuntu#SGX_Video_Acceleration
it requires 2.6.34+,
and I confirmed linux-omap-devkit8000 2.6.34-rc6-g8ee7837-dirty
which is the only one latest bootable, is
unable to load the omaplfb bufferclass_ti.
(FATAL: Error inserting omaplfb (/lib/modules/…): Invalid module format)
(FATAL: Error inserting bufferclass_ti (/lib/modules/…): Invalid module format)
So, I think I met the same problem as the thread:
http://groups.google.com/group/beagleboard/browse_thread/thread/1398cdfc01982f89
; therefore, I want to try update the kernel (modules and uImage).

In addition, I have boot log and bootargs,
If needed, I can post (in a new thread?).

Thanks for your greatly advice. :slight_smile:

2010/7/3 Robert Nelson <robertcnelson@gmail.com>

After I changed from
git://gitorious.org/devkit8000/linux-omap-devkit8000.git to
git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git
, the kernel source generated .deb with same instructions above
successfully!
(got "linux-kernel-2.6.35-rc3-08585-g01c0bca-dirty-1_armel.deb"),
so it's linux-omap-devkit8000's problem, ya?

The defconfig I used: "devkit8000_defconfig".

BTW, I had used the .deb to build my own lucid rootfs by rootstock
successfully,
(linux-omap-2.6 2.6.35-rc3-08585-g01c0bca-dirty)
but it got kernel panic as same as the latest linux-omap-devkit8000
(2.6.35-rc3-g344c93e) when booting,
since linux-omap-devkit8000 boots fine with previous version
before 2.6.34-rc6-g8ee7837-dirty (include 2.6.34-rc6-g8ee7837-dirty).

If it boots fine with the previous, read (lucid section):

http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/annotate/head:/readme.txt

My goal is building a Ubuntu 10.04 (lucid) rootfs
with TI SGX driver enabled on my Devkit8000 baord.
Because according to
http://elinux.org/BeagleBoardUbuntu#SGX_Video_Acceleration
it requires 2.6.34+,

You should re-read that requirement again... It's not 2.6.34 from
linux-omap that's needed, but 2.6.34 from my 2.6-stable tree... I got
fed up with building the sgx driver later, so i dumped them in a
staging tree..

http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/files/head:/patches/sgx/

and I confirmed linux-omap-devkit8000 2.6.34-rc6-g8ee7837-dirty
which is the only one latest bootable, is
unable to load the omaplfb bufferclass_ti.
(FATAL: Error inserting omaplfb (/lib/modules/...): Invalid module format)
(FATAL: Error inserting bufferclass_ti (/lib/modules/...): Invalid module
format)
So, I think I met the same problem as the thread:
http://groups.google.com/group/beagleboard/browse_thread/thread/1398cdfc01982f89

Nope, not the same at all, he didn't have the drivers installed...
omaplfb and buffercalls_ti

; therefore, I want to try update the kernel (modules and uImage).

In addition, I have boot log and bootargs,
If needed, I can post (in a new thread?).

Regards,

2010/7/5 Robert Nelson <robertcnelson@gmail.com>

After I changed from
git://gitorious.org/devkit8000/linux-omap-devkit8000.git to
git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git
, the kernel source generated .deb with same instructions above
successfully!
(got “linux-kernel-2.6.35-rc3-08585-g01c0bca-dirty-1_armel.deb”),
so it’s linux-omap-devkit8000’s problem, ya?

The defconfig I used: “devkit8000_defconfig”.

BTW, I had used the .deb to build my own lucid rootfs by rootstock
successfully,
(linux-omap-2.6 2.6.35-rc3-08585-g01c0bca-dirty)
but it got kernel panic as same as the latest linux-omap-devkit8000
(2.6.35-rc3-g344c93e) when booting,
since linux-omap-devkit8000 boots fine with previous version
before 2.6.34-rc6-g8ee7837-dirty (include 2.6.34-rc6-g8ee7837-dirty).

If it boots fine with the previous, read (lucid section):

http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/annotate/head:/readme.txt

I had add first four entries lucid required into my devkit8000_defconfig before,
so that I can boot lucid rootfs with linux-omap-devkit8000 2.6.35-rc3-g344c93e,
but not the last one (CONFIG_TOUCHSCREEN_USB_COMPOSITE=m).

After adding CONFIG_TOUCHSCREEN_USB_COMPOSITE=m,
still not boot with same errors.

My goal is building a Ubuntu 10.04 (lucid) rootfs
with TI SGX driver enabled on my Devkit8000 baord.
Because according to
http://elinux.org/BeagleBoardUbuntu#SGX_Video_Acceleration
it requires 2.6.34+,

You should re-read that requirement again… It’s not 2.6.34 from
linux-omap that’s needed, but 2.6.34 from my 2.6-stable tree… I got
fed up with building the sgx driver later, so i dumped them in a
staging tree…

http://bazaar.launchpad.net/~beagleboard-kernel/+junk/2.6-stable/files/head:/patches/sgx/

Thanks, I got it.
Maybe devkit8000_defconfig or kernel source
had been broken a while for DevKit8000.

and I confirmed linux-omap-devkit8000 2.6.34-rc6-g8ee7837-dirty
which is the only one latest bootable, is
unable to load the omaplfb bufferclass_ti.
(FATAL: Error inserting omaplfb (/lib/modules/…): Invalid module format)
(FATAL: Error inserting bufferclass_ti (/lib/modules/…): Invalid module
format)
So, I think I met the same problem as the thread:
http://groups.google.com/group/beagleboard/browse_thread/thread/1398cdfc01982f89

Nope, not the same at all, he didn’t have the drivers installed…
omaplfb and buffercalls_ti

OK.