[Beagleboard] Keyboard and Mouse Not detected

Hi all,

I successfully booted Angstrom downloaded from “www.angstrom-distribution.org/demo/beagleboard”(not sure about the version) on my beagle board Revc3. I am able to successfully mount my pendrive. But there is a problem while mounting other USB devices like keyboard and mouse. Board is not capable of powering those USB devices (except USB) . When i tried USB hub (powered externally) , my mouse got powered but is not detected. Could anyone suggest solution to this problem? Thanks in advance :).

In order to connect a mouse or a keyboard to the BeagleBoard C3, you must use a HUB. It does not support low speed devices.


Thanks for your reply. I used a HUB but still it is not detecting mouse or keyboard. I dont understand what you mean by low speed devices. I have USB 2.0 4 port HUB. Even my USB2.0 pendrive doesnt get detect when connected via HUB. My HUB works well in PC . Is there any driver for HUB or Keyboard or Mouse? Thanks in advance.

USB had different speeds. Low Speed (1.5MB/S), Full Speed (12MB/S), and Full Speed (48MB/S). Only 48MB/S devices are supported. That is why you need the hub. Is the HUB self powered or powered from the connector?. You need to use a Self Powered HUB, one that has a power supply plugged into it.

Drivers for keyboard and mice should be included in the Linux image. You can use the image found here and the keyboard and mouse should work.



Thank You Ms Gerald,

I am using a self powered USB HUB. Could you please tell me a bit clearly… What to be specifically installed??

As I said. If you use the demo image you do not have to install anything. It is already built in and works great.


I tried everything… Still keyboard and mouse not recognised… I installed ubuntu too… even with that keyboard and mouse are not recognised…

Does it recognize USB thumbrives or other USB devices? If not, send it in for repair.


Hi Gerald,
I tried using Ubuntu 11.04 for quite sometime, but was never able to
use the netbook image with the keyboard and mouse. They are never
detected. To overcome the problem, I boot the BeagleBoard-XM RevC that
I bought with the default Angstorm image shipped with the box, and as
soon as the keyboard and mouse are detected, I remove that card and
insert my Ubuntu card without powering down the board. I then press
the reset button and this time, the keyboard and mouse are detected.
Can you please help me too.

I thought by sharing my experience, I can atleast provide a workaround
from someone.

So, there is no Hardware issue involved here. correct?


Thanks for the response,

It do recognise the USB Thumbdrives… But the thing is i have to manually mount it through my host PC…