BeagleBoard not working 40W on serial console

I have actually loaded android on my beagleboard and made it to
work.Everything was going fine ..but i wanted to load another version
of android using the sd card.So i inserted the sd card on the slot and
pressed the rest button.But the sd card was never booting even when
pressing user button while resetting the board.I tried several times
pressing user and reset button at the same time..but no use it was
always booting from the flash.So i tried to erase the flash using the
nand erase command on the u-boot prompt and suddenly everything
stopped working ..whenever i tried resetting the board it displays
40W40W40W and nothing else.
Then i tried these links but no avail.
I loaded all the files as mentioned in the Page 134 in in the same order as
mentioned..MLO,u-boot,uImage etc...
Still i see the same 40W40W on the serial console.

Then i thought the sd card might be the issue.So i used another
working beagleboard and inserted the sd card and pressed the reset
button and it worked. i was able to get the TI xloader and u-boot
prompt and the sd card was booting up and working fine.

But the same sd card is not working with my beagleboard.I always get
40W40W while resetting but never loads the x-loader from the sd card.

Did i erase everything in the nand by using nand erase command ?Did i
commit any mistake by erasing the nand and screwed up my board?How can
i get it to work?
Please help me in this regard.

I made the same mistake and erased my NAND. In the end I had to reformat my sd card, make it bootable (for sone reason it was not any more ) and put the demo angstrom files back on. Then I was able to follow the instructions on reflashing the NAND.


Actually my board is not booting from the sd matter whatever i
do it does n't boot the sd card...
As i erased the NAND,do you think that it can't boot by any means.
I think the ROM has the boot order which can be changed by pressing
the user button.If i press the user button,then it should boot from
the sd card...but its never happening.I used HP USB utility tool to
format and write the files..but it didn't help.Is there any way?

Do you have a Linux box u can check if the sd partition is set to bootable?

It is possible that you may have damaged the SD card connector. I would look to see if there were any bent pins on the bad board. Compare the bad connector to the working board.


Hey guys,
good news…i got it to work…i had to make the sd card bootable by
setting the boot flag.i used gparted on linux to set the flag and now
i am able to get the uboot prompt and its working…please add this
in the beagleboard documentation…sd card must be made bootable…in
my case…Thanks anyways…

Yes, if you want to boot form the SD card then it must be bootable. That is what the HP Format tool is for. It makes the card bootable. If you choose to use another tool, then yes, it must also be set to make the card bootable.

Glad you got it working!


It doesn’t always make it bootable I have found hence checking Linux worked for me