[beagleboard] Re: wifi help please

Thanks for the suggestion - I gave this distribution a try and had similar
problems. The dongle wouldn't work at all unless an extension cable was in
place. Overall I've been very disappointed in the wireless capabilities of
the current generation BeagleBone. Others have reported that they could get
it working, but I don't have much to show for many frustrating hours spent
looking for a reliable solution. I've got one of the wifi capes on order,
so hopefully that and/or the next generation BeagleBone will be better.

FWIW, this Ubuntu distribution gave me the following error on startup when
using the dongle, in spite of having plenty of extra 5V power:

[ 2.505512] usb 1-1: rejected 1 configuration due to insufficient
available bus power

fyi: this was just fixed:
https://github.com/RobertCNelson/linux-dev/commit/51363e17a5dd621306d586b594d1ca7d776bdefb

just waiting till 3.8.6 drops in a few hours before being sent to the
builders for a *.deb file..

I was able to work around this by doing the following:

echo 1 > /sys/bus/usb/devices/1-1/bConfigurationValue

The dongle then established a wifi connection, but it's not very solid and
seems to drop out after a while. I don't think it's a problem with my
router since both Windows and OSX hosts have no problems using the same
dongle for rock solid connections.

I've tried the following two dongles under both Angstrom and Ubuntu and had
the same behavior. One uses the RTL8192 chipset and the other uses the
RTL8188CUS chipset.

http://www.intellinet-network.com/en-US/products/9568-wireless-300n-high-gain-usb-adapter
http://www.intellinet-network.com/en-US/products/9622-nano-150n-wireless-usb-adapter

Has anyone else gotten rock solid wifi connections with the BeagleBone? If
so, what is your exact configuration? Do you use an extension cable?

I've had good luck with Atheros arl9170 based chipsets..

I had an issue with Bluetooth over USB on previous Beaglebone images
(Ubuntu and Angstrom) but a March 28 2013 RCN build using kernel 3.8 fixed
this: http://rcn-ee.net/deb/rootfs/raring/ . You need to specify --uboot
bone_dtb (it's experimental still).

Regards,

Robert - thanks very much for the suggestion to try using the Atheros arl9170 chipset. Do you need an extension cable?

Robert - thanks very much for the suggestion to try using the Atheros
arl9170 chipset. Do you need an extension cable?

Did you locate the exact part that we can buy off the shelf ?

I am interested in this as well based on my few days before post on
wifi unstable on Ubuntu + 3.8 kernel.

https://groups.google.com/forum/?fromgroups=#!topic/beagleboard/KqAx0suAXrM

I confirm that this USB dongle does NOT work with 3.8 kernel + Ubuntu.

Ourlink:
http://www.adafruit.com/products/814#Description

And keebox works for a good amount of time and then times out with
some firmware error message - then needed a reboot of system.
http://www.keebox.com/products/productdetail.asp?prod=100_W150NU&cat=66

Based on RCN’s recommendation to try using a dongle with an arl9170 chipset, I googled for adapters using that chipset and ordered a Netgear WNA1100. It arrived today, and I just discovered that Netgear silently changed the chipset to arl9271, which isn’t supported natively by the latest Angstrom distribution. Sigh. Four different dongles now and still no success.

Has anyone enabled the ath9k_htc driver within the angstrom distribution? I don’t want to change over to Ubuntu, and I’m reluctant to go through the hassle of figuring out how to build and load this driver without some hint that it’s worth the effort.