beagleboard recongized as usb-storage


Could someone share their host 's relevant dmesg output when
connecting their beagleboard(revC3) to the host via mini-USB? Doing
this used to activate a /dev/ttyACM0 on my host, and then I'd use
minicom to talk to u-boot. Since yesterday, whenever I power up my
beagleboard, I get a "usb-storage: device
found at 12" and "sd 10:0:0:0: [sdc] Attached SCSI removable disk".

Here's the relevant dmesg output from my host:

[ 448.260516] usb 1-6: new high speed USB device using ehci_hcd and
address 8
[ 448.392962] usb 1-6: New USB device found, idVendor=18d1,
[ 448.392966] usb 1-6: New USB device strings: Mfr=1, Product=2,
[ 448.392969] usb 1-6: Product: Android
[ 448.392971] usb 1-6: Manufacturer: Android
[ 448.392973] usb 1-6: SerialNumber: 0123456789ABCDEF
[ 448.393069] usb 1-6: configuration #1 chosen from 1 choice
[ 448.398027] scsi5 : SCSI emulation for USB Mass Storage devices
[ 448.398133] usb-storage: device found at 8
[ 448.398136] usb-storage: waiting for device to settle before
[ 453.396272] usb-storage: device scan complete
[ 453.396737] scsi 5:0:0:0: Direct-Access <NULL>
<NULL> 0000 PQ: 0 ANSI: 2
[ 453.398220] sd 5:0:0:0: [sdc] Attached SCSI removable disk

Any reason why the board would start to get recognized as usb-storage
all of a sudden? I have not made any changes to the host kernel or
added any modules. There is no SD card connected to the beagleboard.
There is also no other USB device connected to the host.
This happens with external or usb power supply. Also the PMU/STAT/D12
LED next to the power supply is on for 5-10 seconds after power on, is
this normal?
thanks for any suggestions,

- Vasilis

Ok, I hhoked up rs232 to the board.
I didn't mention that the last time i used the board I tried to flash
0xdroid (android optimized for beagleboard) on the board's flash. I
guess it worked because
it seems the board boots in 0xdroid when I power it on i.e. I get a
shell when connecting with serial:

# printenv

# mount
rootfs / rootfs rw 0 0
ubi0:rootfs / ubifs rw 0 0
tmpfs /dev tmpfs rw,mode=755 0 0
devpts /dev/pts devpts rw,mode=600 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /sqlite_stmt_journals tmpfs rw,size=4096k 0 0

does the 0xdroid installer mess up with the board's bootloader?