Beagleboard rev c3 booting but no serial console boot msgs and no keyboard operational

I have a Beagleboard rev C3 which is booting Angstrom OS and Ubuntu 18.04 console.
But there is no boot message on serial console(minimum) and the USB keyboard and mouse are not getting enabled for input/login. Hence I am unable to proceed to login either from board or from the serial console. Kindly help… as there is no way to debug also.

What pins are you connected to for debug port?

Things to check would be if the adapter is configured properly.

GTKTERM works very well, make sure that it is set to the correct USB port.

Check all the basics first.

I connected ATI/EVEREX Cable to the RS232 Of beagleboardc3 and the null modem finally to usb. Tried with an ttl to usb cable as well connecting pin 2 3 and 5 on rs232. Both cases there is nothing on minicom. Minicom set to baud rate of 115200 8N1. Tried other baud rates also. Tried character delay 1ms also. Nothing seems to get output on minicom. Initially 2-3 times got junk on minicom but after some tries that also stopped

Please post a picture of your set up.

The correct pins to use are in the group of 6 male pins next to the header.


I am using the smaller board with rounded corners. My help is of no value with this board, sorry. Some one else might be familiar with your board.

Not an issue, this is beagleboard rev. C3. Thanks for trying to help