[beagleboard] RS485 usage/patch in BeagleBoard/IGEPv2

Hi there.

I'm currently trying to use the RS485 in the IGEPv2 board with the AUTO-Direction change without success.

I'm using the git://git.linaro.org/ubuntu/linux-linaro-natty.git source and applied this patch: (annexed)

This patch was changed accordingly so that the 2.6.38 kernel would be supported.
I believe the patch and its changes to be correct and I added a few debug printk to check its behavior.

My problem is:
I can receive but I can't transmit from the board to the devices...

I already tried a simple problem to just set and reset the RTS line (I don't currently have the source here with me) and the RTS
line is always off...

I also tried to export the GPIO, set the direction as "out" and change its value to 0 and 1 with no success.

I believe the problem could be this:
- The MUX in the uboot is wrong and RTS of the uart is not correctly configured.
- The kernel changes from the 2.6.36 to 2.6.38 changed the serial driver in a way that the setting/clearing of the RTS line is done

Would be much appreciated if anyone could shed some light in this matter since this is driving me crazy!!!

PS: This was taken as reference: http://labs.igep.es/index.php/How_to_use_RS485_on_IGEP_v2_boards

With kindest regards
Carlos Sobrinho

rs485.patch (16.9 KB)