[beagleboard] Running out of options for getting LI-5M03 to work with BB xM rev C

Greetings! I've been working for a while now on capturing images from the
LI-5M03 without much luck. I've tried a few different approaches:

1. Tried building kernel version 3.7 from BB's github. Applied patches and
used the beagleboard defconfig included from github. The kernel worked (as
it loaded correctly), and the device was apparently available in video0, but
image capturing was not possible directly on this device using mplayer. Is
this at all possible with this image sensor, or do I have to use media-ctl /

Correct, i've not seen any other way either....

2. The other approach was to use Max Galemin's Buildroot 2012.02. With
"magic commands" (media-ctl / yavta) run as shell scripts I was able to
capture images, but at <7 fps and a color scheme with heavy yellow tint.
(Strangely, changing the number of images to capture also changed the color
/ hue).

A couple of extra questions: Has anybody successfully used this imaging
sensor with these kernel versions (3.7.x or 3.2.x), is another kernel
version recommended, or is the problem entirely unrelated to the kernel
Is there some important detail or key information that may have eluded me in
my crusade for amazing image-capturing?

Honestly, beyond getting it to work (take a picture) with v3.2.x,
v3.4.x -> v3.7.x based kernels, i haven't done much with the sensor..
Here's a link to the 2 scripts i use, when testing..


That's all i got on the subject...

The hardware is the BeagleBoard xM rev C and the Leopard Imaging LI-5M03
with mt9p031 sensor. I feel kind of silly asking about this, because there
is SO much information out there on this already. Somehow, I still can't get
it to work. Need help!

If anyone has any ideas or thoughts, they would be greatly appreciated!


Thank you for the help, Robert. After posting this, I went back to trying to get kernel 2.6.32 working, following the instructions from Aptina’s github. Unfortunately, I couldn’t get the USB’s to work. Then I went back to Max Galemin’s Buildroot 2012.02, and got everything working, except that the ftdi cable did not show up on /dev/ttyUSB0. Finally, I tried this guide for setting up Ubuntu 12.10, downloaded from your site. This was really straight-forward, and everything was up and running in no-time! (Ubuntu is awesome). After easily getting both ethernet and wifi up, I ran the two scripts from your git repo - everything worked and pictures were taken.

Issue 1 (solved): I seems that when a lower resolution is used (1280x1024) when capturing an image, the captured area is only a cropped section of the whole frame. To put it differently, every image looked like it was zoomed in. I solved this by capturing images at the full resolution (2592x1944) and using the “OMAP3 ISP resizer” step to get smaller resolution images. When I changed the capture resolution to 2592x1944, I also had to change “SGRGB10” to “SGRGB12”.

Issue 2: The images have a yellow tint. I’ve had the same, yellow, result with every build. Do you have any idea what might cause this? I’m wondering if this is a problem with the capturing of the image, or if the problem is with the conversion to .jpg in imagemagick.

Best regards,

Carl Sandaker