Beagleboard start up

when i connected the beagleboard with the pc using serial port first
time , i get the right output as described.
but now when i connect it, it doen not give any output. i tried to
reboot again and again, but the only message on the terminal is "40W "
does anybody have an idea what is the problem ??? and what should i
do ?

The 40W is what the processor sends out when it cannot find a suitable boot source. I would start by providing the board with a suitable boot source by creating a bootable SD card and trying it.


thanks Gerald.
i tried using the above mentioned page, now it boots but it does not
complete the booting.
Does this page work well for rev C4 ?
And Can you please tell me 1 more thing.
What is the difference between preparing SD card by above method and
by preparing by making 2 partitions with the image of anglstorn on
it ??
Does with method 1 , we dont have anglestorm on the SD ?


If you modify the boot partition of the SD card in some ways, you can
upset ability of the OMAP to find the X-loader. Try re-creating the
boot partition. You need to reformat the partition and make a fat32
filesystem then put the files into the filesystem back in the correct
order. Like what you did the first time.

The above link does not contain a kernel image. So i suspect that it does indeed complete the boot, but that does not align with your expectation of a kernel boot.

The first partition must be bootable as a FAT partition for the processor to be able to use it. The format tool we suggest works. Other tools may work as well, but we know that this one does work. As long as you format the first partition to be bootable it will work with both partitions on the card. You can also just use the dd command to copy an image to the card, creating two partitions and the first partition being bootable.


thanks gerald and richard........
Can you please tell me any link which works well for dual partition on
rev c4 board.
I have been trying but could not run it well :frowning: :frowning:

I used the files from the RevCValidationv3 page and the Angstrom demo.
From memory this is what I did.

On the Angstrom demo files page there is a shell script cunningly
named mkcard.txt. It's actually a bash script which will completely
format a SD card, make the partitions and the filesystems. Then you
copy the files into the boot partition as described in the validation

The Angstrom demo tarball of several hundred MB needs to be unpacked
at the rootfs partition (ext2). You must use superused privileges when
unpacking the tarball as it creates device nodes on the SD card.

When the unpack has completed: copy the uImage.bin file from /boot
over the uImage.bin file in the boot partition.
Move ramdisk.gz to another name.

sync to ensure all data is flushed out of filesystem cache into the SD card.

Put the SD card in the beagle and boot.

Note. At this point you should probably check that you can boot the
validation kernel OK.

sync, unmount and boot the beagle from SD.

dear Richard, i cant use the file mkcard.txt.
i copied the file, and use source mkcard.txt but it gives error.

Cant find boot partition in /dev
Cant find rootfs partition in /dev

where do you think is the problem ?

Thanks for the detailed instructions. I followed all these instructions. But the problem comes when I tried to boot my BeagleBoard (BB) using this sd card. It shows me the following message on the hyper terminal. I tried to write root at this screen but I am unsuccessful.

The Angstrom Distribution beagleboard ttyS2

Angstrom 2010.7-test-20110104 beagleboard ttyS2

beagleboard login:

Any one having any idea of what is going wrong?
Why I cannot type root in hyper terminal ?
Please help me in starting my BB.