[beagleboard] Trying Hello_World for first time on beaglebone

First of all, did the device automount ? I am using Debian wheezy i386. Usually devices automount to /media/usb* but It could be slightly different for you.

If the device did not automounted, then you should be able to mount the device then lt should work… example :

mkdir /path/to/mountpoint

mount /dev/usb* /path/to/mountpoint

ls /path/to/mountpoint

Or have you tried this already ?

As for the rest you mention, you need to be clear as to what exactly you want to do. It soudns as though you just want to connect to the BBB to drop files on it but . . . yeah not clear.

I am (eventually) aiming to port http://oceanai.mit.edu/moos-ivp/pmwiki/pmwiki.php (at least the non-visual components). So, I am cross-compiling on the 64bit wheezy box and will want to “drop” the cross-compiled code onto it - as you say. I guess the examples I was using were leaning (I thought) to gaining access to a terminal on the BBB. I guess I was also looking to move to TCP/IP Networking (as described by “TCP/IP Networking - Basic setup” heading on page http://recursive-labs.com/blog/2012/06/15/beaglebone-archlinux-gettingstarted/

At the moment I am windows literate, embedded literate yadda (from my days in realtime acoustics anti-submarine warfare etc) but very rusty on linux.

So, no, usb* did not automount but the BEAGLEBONE itself did so I can read it’s disk contents from the 64 bit linux host.

I note, when perusing the BEAGLEBONE via this method a /Drivers/Linux/FTDI/mkudevrule.sh

Obnoxiously that file is verbatim the same as the suggestion in http://wiki.debian.org/InstallingDebianOn/TI/BeagleBone

So I ran that file. Unplugged BEAGLEBONE and then replugged it in.

It mounted (again) but no /media/usb* or /dev/ttyUSB* turned up.

I will read into the suggestion you made and see where that takes me.





I had to install the usbmount package so I jumped into “Get Software” and installed it. Now when I plug in the BBB, under “/media”, I get:

usb usb0 usb1 usb2 usb3 etc usb7

But I no longer get the BEAGLEBONE mount (as a drive)

Are you by any chance running Wheezy in a Virtual machine ? Sometimes virtual machines can cause problems for USB devices. Which even if not can add an extra layer of complexity.

Sorry if you’ve mentioned this already, but I am viewing these messages via email, and I delete each post after having read / replied to them.

I have played with virtual boxes and found them okay but I love the decadance of the real thing so I have a second hand 3GHz HP desktop running Wheezy 64 bit.

I think I am on my way now with this as I just need not assume things came with the Wheezy installation.

However, I am still bemused that the ttyUSB* did not pop up because, while the examples I used ( http://wiki.debian.org/InstallingDebianOn/TI/BeagleBone and http://recursive-labs.com/blog/2012/06/15/beaglebone-archlinux-gettingstarted/ ) appear to be Beaglebone and not Beaglebone Black, the rule file sitting on the Beaglebone Black seems to overturn any argument that the Beaglebone examples shouldn’t/couldn’t work for the Beablebone Black.

I know the next question is :Why aren’t you running directly off the Beaglebone Black?" and the answer is glib. 1) my linux box is in another room and drive it remotely from my office and 2) because it will eventually be run distributed/remotely on my AUV so I gues sorting out the niggly issues now makes sense.

Just if people are curious, this is where I got to with my setup. The Debian computer is hidden downstairs and in an entertainment center - out of site so it can connect directing via ethernet to the ASDL box. The windows PC is upstairs on wireless connection in my office. I ended getting a wireless extender to get the BBB back upstairs so I can get at switches and signals while I work. I power the BBB by the USB on my PC so I can talk two it via either box. This setup is mostly because its fun :stuck_out_tongue: but also it gives options. I guess I will order the serial cable option as well so I should be able to get at it anyway at all necessary.

Still can’t get at the ttyUSB*, so is it as simple as the ttyUSB* is related to the serial connection and not the USB connection??

The attached image didn’t take for some reason, I blogged the results of my foray at http://organicmonkeymotion.wordpress.com/2013/06/15/beaglebone-black-setup/