BeagleBoard won't flash after interruption - power led only

I started flashing a brand new BeagleBone green powering over USB. The laser back and forth LEDs started but then 2mins in I bumped the cable and made the BB lose power. Now I only get the blue power LED but no others. I’ve tried holding the boot button when powering on for 5+ seconds, resetting the image on the flash card, and booting without the SD card - no luck.

Any ideas?

During the install the file that was being written to emmc might have been corrupted.

If you have a ttl adapter to monitor the debug port that will help greatly.

If you can find a way to force it to use uboot that is on SD card that might get you back up. I don’t have a BB green so I have no clue how to force it to boot entirely from the SD without having access to the debug port.

Hello @mfonk and welcome!

@foxsquirrel want’s you to connect a serial-to-usb adapter to this header here:
(Baud rate is 115200)
Remember, it needs to be a 3.3V type to prevent damaging your Beagle!

This won’t fix your problem off hand, but it will provide us with a better
picture as to what’s going on as your Beagle tries to start.

1 Like

Thanks for the fast reply @lranders,

I plugged a 3.3v sparkfun FTDI cable in with GND towards the ethernet & USB ports and listened at 115200 but get no serial data whatsoever (tx led lights when I type but no rx led action). There is absolutely no action on the usr leds either, seems like the boot process isn’t even starting. For a bit more context, this issue came up only plugging/unplugging the micro USB port. No other capes or connections. The power led is constantly on when plugged in.


Are you sure that is connected correctly. It should have something. Also, if your host is a VM that will be a problem with the USB. The absolute worst case you should see a string of “C” out the port. If everything with the debug cable/host is correct and nothing out, Its done.

@foxsquirrel That’s what I read about, but no, I get nothing. I’m connected directly to my MacBook, no VM. I tried multiple serial monitors including Arduino Serial Monitor. Here’s my setup:

I’m bet I’m just missing something simple just not sure what.


1 Like

Just as a last-ditch effort, could you re-flash your SD card and try booting from that?

You can try both with and without pressing the USR button as you power it on.

Also, you might want to go over the back side with a magnifying glass
and see if any components got damaged by the “bumping”…
Look for any cracked solder joints and obvious scratching.

Perhaps @jkridner or @RobertCNelson has some last-minute input before you condemn it?

No luck with re-flashing the SD and no anomalies on the board itself. I went ahead and ordered another BB and will retire this one. Might try debugging later when I get more time.
Thanks for the suggestions!

@mfonk ,

I noticed that sometimes when yanking power, things can get odd, e.g. no booting, random LED usage, and so on…

Also, use the PWR button to turn off next time if a soft PWR off does not work.


Update, the second BBG is now bricked the same way. This time I held the power button down, waited for the LEDs to shut off, let go of the button but then as I unplugged the LEDs turned back on before I was able to fully unplug. Must have just rebooted instead of shutting off. Lucky me another one is bricked. What am I missing? @silver2row what do you mean by use the PWR button? Should I hold it down until after I’ve unplugged? This has been a pretty poor and expensive experience so far.

@mfonk ,

Hey you, um. Now, I could be totally off base here for the am335x onboard the BBG but what I have seen is that the boards, am335x styles of boards, need to be soft or hard interrupted to be off.

So, a soft off would be sudo shutdown -h now or maybe just poweroff. I am not sure, i.e. as I do not know your image and kernel but sudo shutdown -h now will shutoff the BBG. It has done so for me for years.

I still have one around here somewhere. Yep. There is also hard interrupts that tend to shutdown the boards or restart them. A soft restart would be sudo shutdown -r now or reboot.

The reset button is on the board. The power button is on the board too. There is also another button S2/boot button for predated images that force the image to boot via SD Card. I think this ended circa '17 or '18 with u-boot functionality staging the way.

I am not a wiz but I have ruined some and kept some. I have learned a little bit.

And yes, do not just unplug power via USB from dev. desktop or from the micro USB on the board.

It will brick it at times or at least it used to brick the boards. These days, I am not sure because I have always kept them with soft and hard resets and power offs.


P.S. Hold the power button down until all your LEDs are finally off and wait a bit of a couple seconds to make sure it is completely off before unplugging the board.

I noticed an error in my judgement with an older board, am335x style, from someone somewhere that had the Boris companion on it. Oops. I just unplugged it and thought dang. Now, nothing of what I am saying is truthful depending on if you have a real BBG that boots and can be unplugged with power still on but I like to play it safe.

It could also be that dongle you have attached to the booting UART header.

Try to not use it because of PWR being applied to UART which is 3.3v and not 5v.


P.S. I think only TX, RX, and GND needs to be attached.

@silver2row Thank you for the advice and so quickly. My first and only boot I only waited for flashing to finish (LED cylon went to heart beat) but never did ssh in. I just shut off and unplugged. That last instruction to “hold the power button until all your LEDs are finally off” is what I tried to do but why do you think it restarted then? Next time I’ll make sure to wait a few seconds first. I flashed with the official image: AM57xx 11.7 2023-09-02 4GB eMMC IoT Flasher - BeagleBoard using Balena Etcher to an SD card. Also no action at all on the debug serial port.

1 Like

am335x and not am57xx…

That may be an issue.

@mfonk , try to look under the search icon for latest-images.

Something should pop up. There should be all sorts of images available and ways to “downgrade” and “upgrade” to older/newer kernels.


P.S. Hey, for the BBG, you need am335x images and can write them to micro SD Card via Etcher if necessary. There was some bug in something like ssh and/or .xz files with their utils. So, if something is eerily odd, try to use bmap tools instead. I think I saw something posted recently under bugs about the xz-utils for Linux and FreeBSD or other types of BSD.

Oh my goodness, you’re so right. That’s probably it. Do you know of any way to factor reset the board and/or completely reset the eMMC, @silver2row?

1 Like

Um, I used to understand how to do it. something about blkdiscard.

But, I do not think you will need it. Use the micro SD Card images. Things grew. apt, packages, use cases, and so on…

I think am335x for Bullseye will work well for micro SD Card and then if you can little it to nothing, then you can put it on the eMMC onboard the BBG.


@silver2row That worked! It’s reflashing now that I have the proper image. Just had to hold reboot with S2 held down for it to start off. Thank you so much! You saved me a lot of time and money, I hope this helps others in the future.

I suppose it’s good to be humbled with a simple mistake every once in a while.

1 Like

Yeppers, things change and quickly. So, sometimes images may be good or bad depending on something.

Heads up! But, the ones from this forum, I personally tested.

Now, did I get to do what I intended, not yet but there is still time!


P.S. And that dongle for the UART header for seeing kernel oops and other things, only use TX, RX, and GND.

This will save you far less worry about if the board is supposed to boot or not. So, only 3.3v to/from TX/RX and then GND. Do not apply any 5v logic to the BBG or you can bypass kernel oops and have a busted board, e.g. or the am335x may malfunction in general or at least the last resource for a common way to debug booting issues.

1 Like

I appreciate the time you put into personally testing and helping me out. That makes sense, I’ll be sure to be more careful in the future and especially avoid 5V logic into the BBG.

Yeppers. I am sure there is a way but for lackies like me, I tend to stick with 3.3v logic around the BBB/BBG boards from older times.


P.S. They are useful still but I have not been able to account for what happened and when… Oops. Lack of notes during changes kept me back. I totally missed out on building around newer boards that will be supported for years (a good outlook). I am not sure if the am335x style of board will keep up with support like the newer, more recent boards, e.g. tending to the future of times. But, I am just hearsay playing now.

Thank you for chatting with me. I am glad it was so easy to figure out. I never figure anything out to tell you the truth. Phew.