Beagleboard xM 1GHz support

I just upgraded my Beagle xM to the latest release at
http://rcn-ee.net/deb/natty/v3.0.0-d4. I was hoping to now get 1GHz
support as I thought that support for such was added upstream sometime
in 2.6.39. I changed the mpurate to 1000000 in boot.scr and get a
"clock: dpll1_ck: unable to set MPU rate to 1000000: -22". I also
tried a mpurate of 1000 which caused the kernel to hang.

Thanks.
- Jim

and that's the reason it's still not 'enabled'.. :wink:

There's still a few non mainline patches needed to enable 1Ghz reliably..

Check out Koen's patchset here:
http://groups.google.com/group/beagleboard/browse_thread/thread/37bcc8118402a4a2#
Which includes much of what's going in 3.1...

Regards,