Beagleboard XM is dead? LED13 flashes and then nothing...

Hi,

My BBxM had an overvoltage or I have probably removed my mmc when the bb was powered on.
In any case, the D13 led flashes and then nothing happens. No serial output. I tried reset and user
buttons but nothing.
MMC data (boot and linux) are OK.
Probably I have only a BOOT problem… I don’t know.

Please, help me.
Thank u in advance.

Sounds like you need to try for an RMA.

http://beagleboard.org/Support/RMA

Gerald

I cannot, so please could you explain all possible ways to solve this problem?
Or in any case, how could I make a simple diagnostic of BB fault/problem?
Is there a way to reset the Board?

Thank you in advance

There's also a chance by "removing mmc card" while powerd on, you've
corrupted it's boot sector.. reflash the mmc card..

Regards,

… but CAN I do it without deleting old files… or re-copying them?
Could you explain the steps?

Thank you in advance,
Plc

NO, not with the older omap3 bootrom.. For later devices omap4/am335x,
it's not as "PICKY", and some times you can get away with just
recopying the MLO file..

So using a second microSD, reflash that one to verify this is
actuallly the problem..

If that fixes the issues you can copy your files from the 1st microSD
to the 2nd.. rsync works great and is trival..

Regards,

Ok, but ,please, could you me post the link with instructions to flash a new microSD.
I’m using a pre-built micro SD.

So I have to:

  • make 2 partitions (boot, part1)
  • make boot partition bootable
  • copy boot files from old to new mmc
  • copy linux files from old mmc to new mmc

???

But in any case, a bad mmc could cause no print (no communication of any kind) on serial port? Could it be?

Thank you in advance,
Plc

Ok, but ,please, could you me post the link with instructions to flash a new
microSD.
I'm using a pre-built micro SD.

You can download the original Angstrom image from here for the xM:
http://beagleboard.org/latest-images

So I have to:
- make 2 partitions (boot, part1)
- make boot partition bootable
- copy boot files from old to new mmc
- copy linux files from old mmc to new mmc

or background here:
http://eewiki.net/display/linuxonarm/BeagleBoard#BeagleBoard-SetupmicroSD/SDcard

???

But in any case, a bad mmc could cause no print (no communication of any
kind) on serial port? Could it be?

Yes, on the xM, if the device can not see the MLO file on the mmc,
it'll print out a random character, a number, followed by a few more
random characters and then halt..

Regards,

mmm… but the problem is that no character is printed on serial port.
No char… so?

Ugh, it's up to you... Either throw the board away and do something
else.. Or... Take 15minutes re-flash a second microSD and see if the
board is fine.. Like you said... All you did was remove the microSD
while it was running, unless that was a lie.. :wink:

Regards,

I have done it.

I have built 2 partitions and I have copied my files. Nothing is shown on Terminal.
So? D13 Led just flashes once and all other leds are still off.