BeagleBoard -xM not booting up....

Hi All:

I just got a BeagleBoard -xM. I was reading the documentation and it
seems that it doesn't have anything in flash. However, it comes with a
pre-installed Angstron distribution in the micro SD card, so it should
boot up after power it up.

However, connecting serial port to the PC (115200,N,8,1), and powering
the board (I tried both; via miniUSB and External Power), It doesn't
seem to boot it up at all....

Initially, I was using Windows with a USB-Serial port converter (this
laptop doesn't have serial port available) and all I get is
garbage...Then, I tried with a Linux-based laptop, and a kind of
prompt appear (a series of spaces followed by 60...) but it still
doesn't boot.

What else can I try? Is it something wrong with the board? I read the
User Manual, and it suggest that Angstron should boot up. At least, I
should see an error message..

I would appreciate any help on this.


What are the LEDs doing on the board on power up? What power supply are you using?

If you are getting the series of characters and a 60, then it is not seeing the SD card. Also make sure that you do not push the User Button on power up or after a reset.


Hello Gerald:
Thanks for your support.

Right now, I 'm testing it powering it up using miniUSB.
With or without the microSD card, every time I power up the board, or
after pressing Reset button, none of the USR0/1 LEDs go on. Only the
POWER LED is ON. The User button is not pressed...
At this moment I'm using my Windows laptop (with the USB-Serial
coneverter and TeraTerm) and I can see a kind of prompt, but something
like this:
QT,0 @ø6Á:ìØb`ÀU

Once I press Reset, the prompt appears after few seconds...If I press
Reset while User button is pressed, the prompt appears immediately.

Should I try with a new SD card? (prepare a new one...)

I would appreciate any help on this.

You really need to power it from the power jack. A typical USB port will not provide enough power for everything on the board. It should allow you to boot it, but it will cause issues once you get past that point.

What revision of the -xM do you have? I would rework the SD card, but the image you need to use depends on the SD card.


Hi Gerald:

Using an external power supply doesn't change the things...
The board I have is revision C (I guess is the latest because
documentation rev A3 only mentions PCB rev B)

Anyway, I just checked the microSD card and it's empty (only
LOST.DIR). Isn't supposed the Angstrong distribution should be there?
So I guess I will need to prepare the SD Card. Do you have any
specific advice in this case?

Bad out-of-box experience for a newby like me...I hope have it working


Interesting. OK. Go to the following link below and follow the instructions to make the SD card. BTW, all you will see is the FAT partition if you read the card on a Windows PC. You will never see the second partition where the Angstrom kernel is located.


Hello Gerald:

Now, it really worked!!!

Thanks a lot for your support.


Glad you got it going!


Hi Gerald,

I have the same problem with booting up the BB-xM rev.B. I used my own
4GB SD card to boot up the BB -xM. The boot partition of my SD card
contains my u-boot.bin (configured for GPIO pins on expansion header
and auxiliary header), uImage 2.6.29 and MLO. The root partition
contains rootfs and also uImage 2.6.29. When i used this SD card to
boot BB-xM, it seemed that the BB didn't detect my SD card, i also
pressed re-boot button, but nothing happened. However, when i used
this SD card to boot-up BB rev.C2, everything was alright, the BB C2
run and logged into Angstrom.

I really don't know what kind of problem i'm facing with. Could you
give my any advices?
Besides, i try booting BB-xM with the mini SD Card coming with the
original box, then the BB xM is booted.

Ngoc Son Dao

The User Button i snot to be pressed on the the -xM board for booting selection. All it does it cause the board not to boot. You need to make sure you follow the instructions and format the card correctly.


Hi Gerald,

I have experienced the same problem too. However, I managed to make one micro SD card that can boot up. And, I failed to do it successfully again since then. I believe I did follow the instructions and format the cards correctly. The -xm Rev B board has on-chip NAND, I believe it was programmed. But, I do not want to erase it because I am afraid to make the -xm board failed to boot even with the boot-able micro SD card.

Best Regards,

The Rev B -xM cannnot boot from the NAND that is on the board. The boot pin strapping does not support booting from the NAND. I would erase it as it is not used.