BeagleBone AI-64 hanging while running edge_ai_demo

Hello Community,

I am trying to run Edge AI Demo from /opt/edge_ai_apps.

I am running the demo with the following configuration:

title: "Object Detection Demo"
log_level: 1
        source: /dev/video2
        format: jpeg
        width: 1280
        height: 720
        framerate: 30
        model_path: /opt/model_zoo/ONR-OD-8050-ssd-lite-regNetX-800mf-fpn-bgr-mmdet-coco-512x512
        viz_threshold: 0.6
        sink: /opt/edge_ai_apps/data/output/videos/output_video.mkv
        width: 1280
        height: 720

        input: input3
        models: [model3]
        outputs: [output3]
                width:  1280
                height: 720
                pos_x:  0
                pos_y:  0

When I run this either using CPP or Python, the BB AI-64 gets stuck, terminal freezes and ask me to reload the browser running VS code. And, sometimes it just power-off.

I am using the image from here

Here is the image for stuck terminal

Please help and let me know where I am going wrong.

Thank you


Hi Shubham,

I tried the same configuration with the Image you shared
It works fine for me
Can you run the demo with -n option and share the log

sudo ./ ../configs/object_detection.yaml -n

Rahul T R

Hello Rahul,

Thanks for the reply.

I tried with option -n and here is the output. I get bitrate command not found error.

When I edit the python script ‘’ and remove the bitrate=10000000 option. It crashes like earlier (see below)

When I change the output to:

        sink: /opt/edge_ai_apps/data/output/images/output_image_%04d.jpg
        width: 1920
        height: 1080

I have also tried running from this repo here

It works fine for a model with input 320x320. As soon as I try to run for models largen than this (512x512 or 640x640) BB AI-64 crashes. It crashes without giving any error, just everything hangs and BB AI-64 reboots.

Can you please tell me which version of edge_ai_tools you are using?
I am using the one which shipped with the above mentioned image.

But, this problem looks consistent with running large models. I guess there is some memory management issue which I am not able to figure out.

Thank you

Does it reboot without any errors?
If so, it’s a power connection issue.
The model draws up to 17-20 watts when running.
USB-C type 5W 3A is not enough.

I solved the problem by using a barrel jack 5V 5A.

If the model reboots for no reason, check the power source.
At the very least, the power should be at least 5V 4A for it to run stably.

1 Like

Hello Alex,

Thank you very much. This solved the issue.

The power output was not enough from Laptop, I used a Type-C adapter 5V 3A and it worked. I will also order a power adapter barrel type 5V 5A.


I’m glad you found it helpful.

I also have TI’s DevKit board, SK-TDA4VM, so I checked the datasheet, and it says that the TDA4VM core alone consumes more than 15W.
The SK-TDA4VM supports USB-C PD, so it can support 5-20V 3A (up to 60W) to run the model, but the BBAI-64 only supports 5V 3A, so you may have power issues.

To run edgeai models on the BBAI-64, we recommend a barrel jack charger that supports 5V 4A or higher rather than USB-C.

Hello Alex,

I just received a 5V 4A barrel jack adapter (ordered 2 weeks ago) and will try it now.

Thanks for the information.


Hi Shubham,

I’m about to order a 5V 4A barrel jack adapter as well. Was your Edge AI demo able to work properly now with it?

Thanks, Paul.

Hi @pauljhan01

I am using 5V 3A USB-C and it is working perfectly fine. I ahave tested by running it continuously for 10+ hours while doing Inferencing.

I guess, 4A should be more than enough.

Thank you