Beaglebone and Chromebook connection

Hi all,
I’m trying to connect a Beaglebone to a Chromebook without any luck. The network connection doesn’t seem to get established.
Only time it worked was when I had to reboot the Chromebook after I received an OS update. Once I logged in, the network was up. I didn’t manage to get the connection up again after that once time.

Thanks for your help.

Here is one method. Get the “Secure Shell” extension. This will give you a Linux style terminal in a tab. See if you can:

ssh root@

If your IP address is different, adjust in the above command.

I’ve tried this and it works. I didn’t do anything beyond testing to see if it works. I normally use a Linux desktop to work with my Beaglebones.


What Beaglebone image are you running? I’ve found many of the recent images have issues with getting the “USB gadget” Ethernet over USB to work reliably. Without the USB gadget interface the ssh debian@ will not work. Can you try a wired Ethernet connection? Then the ssh login should work to the IP your router assigns to the Beaglebone.

Hi Wally,
Thanks for your reply.
I’m using the latest Debian image from the downloads sections. Also I ran apt-get dist-upgrade to make sure it had the latest version of all the packages.
I need to investigate the ‘USB gadget interface’. All I know is that from the linux side, it seems to be up and running with IP address From the Chromebook side the interface doesn’t seem to come up. If I manually assign the ip address to, I still can’t ping each other.
I imagine that when you say ‘wired’ connection you mean using a regular ethernet cable rather than USB. Ethernet works just fine, but it kindof makes it clunkier than having a Chromebook ->USB->Beaglebone.

Hi Greg,
Thanks for your feedback.

I have ssh on my Chromebook, but this doesn’t work as I can’t even ping the beaglebone. The network needs to be up before I can run ssh or http, etc. Just trying to figure out how to get the network connection established.

Hi Christian,

Out of curiosity I just tried connecting my Samsung Chromebook to my beaglebone using a standard USB cable and it worked fine. Note below that the Chromebook is getting a DHCP address from the beaglebone, but otherwise it’s okay.

If you continue to have trouble you can open the Chromebook terminal and type help_advanced. That will give you access to the Chrome dev shell where you have access to route and dmesg to help in debugging, which will show that there is a route created between 192.168.1.x and 192.168.7.x.

> route
/0 default via dev mlan0  metric 1
/1 []( dev mlan0  proto kernel  scope link  src
/2 []( dev eth0  proto kernel  scope link  src

Screenshot 2016-04-03 at 21.40.48.png

Hi Paul,
Thanks for posting this info.
There might be an issue with my Chromebook then because they network doesn’t seem to come up. Just out of curiosity, which OS image are you using for your Beaglebone?
Also yesterday after I finished running apt-get upgrade, all of the sudden they USB network started working. Of course after I rebooted the Beaglebone never came back up again.
When I get more time, I will play with different Linux images on the Beaglebone see if that changes anything.

Just out of curiosity, which OS image are you using for your Beaglebone?

​It was in the screenshot.​
​ Machinekit Debian Image 2016-03-13
Linux beaglebone 3.8.13-xenomai-r17​

I can confirm that when I connect the beaglebone to the chromebook and power up the chromebook, the network never comes up, but if I get an update on the chromebook and can ‘soft’ reboot it without shutting down the beaglebone, when the chromebook comes back up, the network is up. If there was a way I could reboot the chromebook once the beaglebone booted up, that would fix my problem, but from what I can see, there is no way to do a reboot of a chromebook, except for when you get a system update.

The trick is creating a network route to the USB gadget. If you are familiar with a unix style command line, the tools are there to mount the 192.168.7.x network in the Chrome OS terminal. I am travelling and don’t have access to my BBB, but I’ll try later when I have physical access, rather than over a VPN. Chrome OS should automatically mount the USB device (BBB) as a network device, just as it would a USB-LAN adapter or USB-wireless device. Chrome OS has to see a dhcp server on the 192.168.7.x network of the connection will fail unless you explicitly mount the BBB on a static Chrome OS address. At that point, you might as well just use the built in BBB ethernet adapter.

You will have exactly the same problem in Windows 7, 8.1 and 10; there has to be a route to the 192.168.7.x subnet. Either you need a router on that subnet or you need to specify a route explicitly.

Kind regards,

I’m seeing the same behavior on a newer 4.14 kernel beaglebone image. If the Beaglebone is already booted up and connected to a Chromebook, then the USB device will properly be assigned the address. If the Beaglebone is powered over USB, though, the Chromebook seems to not see a network device when it’s immediately plugged in, as it hasn’t had time to boot, and never checks again. I can switch the Beaglebone board over to a 5V power supply, unplug the USB, replug it in and the Chromebook is able to connect without issue. This seems like a Chromebook issue to me, but does anyone have any suggestions for how to fix this?