BeagleBone and ubuntu??

Hi, I’m Giorgio, I read about Ubuntu around on the net, but… I just found tutorial on BeagleBoard xm, I’d like to use php and mysql. How can I use them??

  • Installing ubuntu for arm? And do you have some advices where to find a good tutorial (I have a beaglebone)?

  • Lighttpd, in base installation of Angstrom distro (but mysql)??

because I tried to install apache, but there isn’t any library on Angstrom distro… :frowning:

ps: how you can see I’m completely newbie on this argument… :stuck_out_tongue: Thanks a lots!!

You can use a pre-installed Ubuntu image for the Bone, see the
following instructions:


wow… that’s wonderful!!! I skipped some trick over that tutorial… so sorry… Thank you so much!!! :smiley:

so… I can start to play!!!

Educate me - how do you plan on playing with a board which has no
video out? Don't tell me you expect to see serial output console etc
identical to running Linux on a Linksys router? The routers are $25
bucks now days, am I missing something about the value of the
remaining $50 for the Beagle Bone price point?


Wow, Your completely missing the point of the BeagleBone...

Unless your a volume customer, there's now way you can build a product
with the chipset used on the Linksys router..

DVI adapter for the BeagleBone:


I bought a BeagleBone, because I can make a program with an other pc, like webserver or what u want (drone, robot, really as u want) and then install it on BB… I hope I shown u what we could do… :slight_smile:

An example, I don’t like use “Arduino” because in Arduino we have low low low memory, and justbecause it doesn’t have so much I/O and it’s NOT an OS…

Dot… :stuck_out_tongue:

I've been using ssh -X with an Xserver. Emacs pops up on my host machine and a terminal server lets me do development stuff. My friend is doing java development by mounting a folder from the bone on his desktop machine. Then he uses an ssh session to run the app or a web session if it's an applet. The bone is a full linux server; you play with it just like any other linux box. And, no, most people I know don't use a serial console for anything more than watching the system boot.

I have been trying to do the same with the Bone connected to my network 192.168.10.x. It's the only connection I have currently.
I used ubuntu-11.10-preinstalled-desktop-armel+omap.img and added the lines to /etc/network/interfaces and booted it up, but nmap doesn't find it.

Two questions (I know these are simpleminded but I'm a simpleminded kind of guy):

First, are you sure you are really booting? My first bone magically booted and when it stopped working, I thought there was a network problem. Turns out it was a SD card problem. And, bonedrv.exe hadn't worked for me so I couldn't check the console. Turns out, contrary to all my previous experience, the bone has to be plugged into the usb slot before bonedrv will load the drivers. This caused me infinite grief because I "knew" how to install drivers for usb devices. And, pressing the reset button causes the serial port to go away temporarily (if you are only using usb for power) which causes putty to shutdown. This makes getting the very first part of the boot process somewhat tricky.

Second, have you tried setting a static IP address? Since you can edit the interfaces files, taking out the dhcp step would eliminate one possible source of failure. May not help but it can't hurt.

Third, that isn't the ubuntu that I got working. The one I used is ubuntu-11.10-r3-minimal-armel.tar.xz found at Yours may be OK but I know this one worked.

Like I said, simpleminded. But, I "knew" what was wrong and lost several days of getting things done because of it.

Good luck,