Beaglebone Black aways losing the SSH connectivity

Hi gyus,

I’m trying to find a solution for this SSH problem, I already tried to use these solutions:!topic/beagleboard/Ya2qE4repSY ,!msg/beagleboard/Ya2qE4repSY/u4lvOjF66JEJ
The only way that I’m able to access the command-line on the Beaglebone is using the ‘screen’ command on Mac OS X. I tried to recover the SSH by using the command-line and tried to clean the configuration of the Dropbear too, but I couldn’t make it works.

The only solution that I worked for me was to re-flash the Beaglebone’s MMC and reinstall everything from the beginning.
Is there a way to create a flasher SD image with custom softwares, making easier to reinstall everything?
Or is there a way to reinstalls the SSH server on Beaglebone?

Thanks in advance,
Vitaliano Palmieri Neto
Programmer @ Iceland 2nd Nation

Have you tried to use openssh instead?

(use opkg instead of ipkg as listed)

I simply made a cron job that performed something like “systemctl start dropbear.socket” periodically. You could have the script detect if dropbear.socket is dead, and restart it.


I’ll try to work with the cronjob first and then I’ll try the OpenSSH.
Soon as I fix this, I’ll post the results.

Thanks again, guys!