Beaglebone Black Board problem to boot from SD card

Hi all,

this is my first time working with a BeagleBone Black Board. I tried setting up my Beagle Bone Black Board, but I think I made a mistake during the progress and now my board isn’t working anymore. So I tried to reboot the board from the sd card but unfortunately without success. Here is roughly what I did.

I wrote the image “bone-debian-8.7-iot-armhf-2017-03-19-4gb.img.xz” on a new SD card. Then I put it into my BeagleBone board and connected with ssh with the board. Then I went into the folder “/opt/scripts/tools/eMMC” and used the command “sudo ./”. Afterwards I got an error message, which I unfortunately do not know anymore and since then only the power LED is on and no connection to the board is possible anymore.

So I tried to reflash the board according to several instructions I found in this forum. For this I installed a new imager on the SD card and tried to get my board to boot from the SD card by pressing the S2 boot button. Since somewhere the tip was that the S2 button may be broken, I have also tried to close the short. Furthermore, only the power LED is lit and no connection is possible.

I am very happy about every tip, idea or link. Thanks in advance!

Have you got a serial cable for the board. Would be very helpful to see exactly what is going on

That script was for a specific set of directions…

Just grab the latest ‘flasher’ for either Buster or Bullseye…


Thank you for the tipp. Unfortunatly I don’t have such a cable but I will order one and test it.

Thank you for the information. However, I am not even able to flash anything as it doesn’t even react and only the power LED is blinking.