Beaglebone Black does not send any data on debug port - scope shows no data

I have flashed my BBB with the minimal version from this site:

After inserting the card into the board and powering up (2A supply) there is no data sent over debug port J1 (pin 1 = GND, pin 5 = Tx)
I have checked with a scope, the level is constantly 3.3V high, no data.
I have tried with different other images as well, there is no data in any case.
I have also read couple of posts hre in the forum, in most of the cases was a problem with connecting to the right pins of the FTDI adapter.
But in my case I do not even connect cables, only watching the signals with a scope, and there is nothing coming out.
Is there a need to activate somehow this debug port before being able to use it?
Thanks in advance.

No, the factory images have it turned on.

Does the blue light come on?

Yes. The usual LED sequence on power on, then later on only the heartbit LED, and sometimes very weakly the SD card access.

At this point it would be best to use a TTL to USB converter on your linux debug port. If the heartbeat is on the board is up.
If you are using a VM expect issues with the USB ports.

If you have the same adapter that we are using the black wire goes toward the ethernet jack and the green towards the USB jack. Assuming you have the 6 inline connector on yours.

Also, on your host if it is linux

$ sudo usermod -aG dialout <your user name>

Then reboot, before doing that

$ groups

If you are already in dialout skip adding the group.

1 Like

Hello @Steve12 ,

I sometimes build appliances out of the BBB and adding power via the mini-USB in Linux after attaching the TTL_to_USB cable to BBB target/Linux host works for me. Also, like @foxsquirrel says, dialout needs to be in the groups.

One thing I use, that someone taught me, is tio. It is as simple as trying to make the command tio /dev/ttyUSB0. Sometimes and in some cases, tio /dev/ttyUSB0,115200.

Also, I know what you have listed as what you are trying. I have not tried using an oscilloscope on the UART0 debug header on the BBB yet.


P.S. If you just want to test data coming to/from the UART0 onboard the debug header, maybe try adding in dialout to your groups and/or use tio /dev/ttyUSB0 and see if that helps in your O-scope testing…

The duration is way too short. Unless you have a DSO and have it set up in advance nothing will be seen. You can send a huge text file with the same character while playing with the DSO to get it to decode. These new color scopes are nice but you need a technician to set the thing up. I miss the old Tektronix 475, you could just turn the knobs until you got a signal that looked usable.

1 Like

Well, actually the main issue is that BBB cannot be reached over Ethernet.
Then I wanted to check the debug messages. I connected TTL UART bridge (CP2102) to J1 GND and Tx (pins 1 and 5 of J1), but saw no data. That is the reason why I checked with the oscilloscope, and acknowledged that the adapter is not faulty.
So I thought maybe first solve the debug issue, then I can eventually see why is not reachable over Ethernet.
I checked my router to see all connected devices on my home network, but saw no new IP which could be assigned to BBB. Also, beaglebone.local cannot be found (timeout). My network is OK since I can see other devices (I have a RasPi Zerowhich is accessible).
Any thoughts on this?

Do an overwrite erase on your SD card and start over. Something is terribly wrong and will take more time to debug. The factory image for the BBB works extremely well. You should not be having troubles like that.
Make sure that you let Balena etcher or Pi imager verify it.

Regarding your router, if you changed the hostname of your board and it still has the same MAC you will have some issues that require removing the DHCP reservation for that specific MAC. Becareful deleting stuff you can break your local network. If you are not sure don’t touch it.

I did flash the card 4 times with Balena etcher different iimages, same behavior:
if I plug the card into the board it will not boot from SD card. In this case it does not get any IP address assigned over DHCP.
Only if I power up by keeping the boot switch pressed, then it boots from the card and is visible over network.
So either the card is faulty, or Balena does not flash it correctly in order to boot from card.
What should I do to set the board to boot always from SD card?

To make the BBB always boot from SD card you need to wipe the eMMC i think. The first MB would probably do the trick. Obviously only do that if there is nothing on the eMMC you need.

Make sure you downloaded it directly from their site I believe it is
Don’t recall what we did to ours, they all boot from SD and it might be what @benedict.hewson suggests regarding wiping the emmc.

Yes, I’ve found that in another post, I did that and it worked.
A jumper would be nice to select the boot device.

So, now that the board boots from SD card, back to the original issue: what is wrong with the board, why I don’t get anything on the debug port?
Any ideas?

There are a few possibilities.

(based on revc3 schematic) EDIT: U15 is a buffer not level shifter.

  1. your sd card image is faulty ( unlikely if it is booting and lights are flashing)
  2. you can’t work a scope ( I assume if you own one, you can)
  3. there is a level converter (U15 underside of the board) between header and CPU
  4. the UART pins on the AM3358 are dead.

If something has gone, the most likely candidate would be the level shifter.

If you are good with a soldering iron you could solder on some test wires and check the signals between CPU and U15, It is a very fine pitch chip so you would need to be careful doing this or you might make things worse.
Replacing it would be possible if faulty.

If you have a second working BBB you could also try the sd card in that and then use your scope on the header pins to check that you are getting a trace, just to rule out 1 and 2 above.


Were you using a 3.3 V level ttl to usb adapter?
FYI, I bought a large number of the level convertors from an online site and none of them actually dropped the level down to 3.3v or even close. So it might be a good idea to scope that and make sure they are actually working.

Also, if the air is dry and your shoes and flooring are conducive to generating static you might have blown it while making the connection.

The serial TTL to USB adapter is ok.

What is not ok is the serial buffer U15 on the board - thanks @benedict.hewson for the hint, I haven’t expected any buffer there.
On 2A input I can see serial data with the scope, on 2Y output no data, but 3V3 steady.
So I think we can conclude that U15 is faulty, that is why J1 pin 5 is “silent”.
Unfortunately I have no experience on replacing SMD ICs, so I will leave it this way.

Thanks to all of you for your support.

1 Like