Beaglebone Black doesn't recognize usb devices from its type A port

i connect my beaglebone black to the computer via the default cable and ssh into it. I use ethernet from my computer as the internet connection. I even did some stuff with it through the gpio pins and communicating with a ublox receiver through uart1. Now I want to use wifi on the beaglebone black and for that i have a MT7601 antenna that goes into the usb port (type a) but the board seems to not recognize nor give power to it. Then I tried to connect a bunch of usb peripherals to it including memory sticks and it didnt recognize any of them, so I am thinking, is the usb port just broken? I also measured it with a multimeter (black to the ground pin and red to the pins inside the usb port, i tried all) and it doesnt show any voltage. I was wondering if theres some sort of boot setting or hardware config where i can make it so it sends power over to the usb port or is it just faulty hardware? Its kind of an old board i think

If you want to actually use the USB port on the BeagleBone Black, you’ll need to also plug in the 5Volt DC jack for power. Otherwise you are limited by a very small amount of power from the your PC powering the BeagleBone Black.


1 Like


That is a fact jack. I noticed a lot of things in my light so far. Life/light/whatever…anyway.

I see that the BBB needs external power via 5v at times when specific, heavier hardware is associated w/ the BBB…

Sometimes not so much but at times, yes. I have had some dongles work while others not so much. I thought I was confused or dumbfounded…



P.S. This is just a reconfirmation of utilizing the barrel jack on the BBB for more current. 2A is by far enough also… Enjoy! Again, and I repeat, this is a reconfirmation.