BeagleBone Black ethernet - no lights


I’m a proud new owner of a BBB and still in the Newbie category when it comes to terminal commands. I’ve been able to successfully boot my BBB using Angstrom, I’ve even been able to connect to the internet (at first) using an Ethernet cable. I have not been able to get the wifi to work - I have the recommended Edimax wifi dongle (and know it works), but “opkg update” is not successful. I tried switching to Ubuntu instead (which I am more familiar and which I know how to connect to the internet…at least with the desktop version). But, sudo apt-get update doesn’t work, so I can’t install ubuntu-desktop either :frowning:

That’s not the reason for this particular post though.

About the third time I tried using the Ethernet, the connection kept connecting and unconnecting. That’s when I noticed that the green and yellow network lights were not staying lit. Now, I cannot get them to light at all. So, before I can address the problem with updating, I need a network connection.

Could there be something wrong with my board? Or, have I possibly messed up a setting that “turned off” the Ethernet connector?

I would appreciate some troubleshooting advice…currently, I have Ubuntu flashed to the on board memory. If it helps, I’ll switch back to Angstrom.

Thanks in advance for your assistance,


Try a different network cable. IF that doesnt fix it, try pressing down firmly on the ethernet jack on the BBB

An oddity I had was that I required external power to the board for it to boot over an NFS network connection as otherwise it would drop out and sometimes fail while Booting Linux…

  • Nick

I power via USB ( USB 3.0 ), and I’ve had no such problems. I even boot via NFS / tftp.

Thank you for your replies. I have tried different cables, as well as different connections: i.e. from the cable box vs. the wifi router. When I get home, I’ll try “pressing down firmly on the ethernet jack” so see what happens.

Look into the ethernet connector and check the actual pins. It should be obvious. My first beagleboard black had a broken pin.

Update: I’ve flashed back to Angstrom and tried again. At least the Ethernet lights light up, but they won’t stay on. When I go to network connections I only see the “ethernet” option for a few seconds at a time. And, I tried “pressing down firmly” as well as using different cables and ethernet sources. No luck so far. Perhaps I do have broken pins, however, its not quite obvious to me. Where do I look for the pins?