Beaglebone Black Ethernet - Software solution not working


I am using Beaglebone Black, Kernel version 4.14.71-ti-r80. In few boards, after reboot the eth0 IP address is wrong and it couldn’t connect to internet. Tried to make this software solution which didn’t work in my case. I run that script manually and see if the PHY address are good. It doesn’t seem to detect good or bad state accurately in my case. Anyone who tried this solution help me in fixing this or have any other software solution?


Have you tried to use debian@beaglone.local yet? I know this is supposed to work w/ Win and Linux Distros in general.


P.S. If this is not what you are describing when trying to sign in, please forgive me. I will try to understand better soon. Oh and sir, that is a an outdated kernel (sort of). I think more recent kernels may have preferences associated w/ “the” phy issues that are resolved.

@silver2row it’s a different issue, more debugging is being done on irc…



Hi guys,

We had a discussion in beaglebone chat Came to know that the problem I am facing is not exactly the PHY issue. So the software solution I tried to derive from the link I mentioned is irrelevant in my case. Not sure about the correctness of log I saw in checkphy (good and bad state). Anyway I am going to revoke the implementation as this is not required solution in my case.

Thanks and Regards,
Raajeshwar Elangovan.