BeagleBone Black: Ethernet transmits packets but does not receive them

Any resolutions to this issue? I am experiencing the same thing on BBB running Ubuntu 13.04. When booted without a cable plugged in, the board can never get an IP address.



I too have seen the problem both with Angstrom and Ubuntu (13.04). RobertCNelson suggests: “I believe it’s a problem in the cpsw ethernet driver.” (see above). Presumably both Angstrom and Ubuntu pull in the same low level driver.

It is not clear (to me at least) whether that means it is a problem which the community can/should fix or whether it is something that TI need to be made aware of so that they can fix it.
Can anyone clarify?

I RMA'd mine and they diagnosed a faulty ethernet controller, but nothing more specific yet.

Interesting Louis, presumably you have received a new board now - can you confirm whether you see the same problem of no reconnection when you unplug the LAN for some seconds?

I have 3 BBB boards here (2 x A5A and 1 x A5B) which all do it so if it is a fault with the ethernet controller, there must be a bad batch - seems more likely to be SW though.

Yes I have the same question - is there actually a h/w fix?

There are some pretty relevant-sounding cspw driver fixes logged in Tony Lindgren’s repo: I think they are against a 3.11 kernel so maybe they are coming (soon I hope? - testing them on BBB exceeds my linux chops / available time). But this blog post says will have a 3.11 build this summer:

So my current strategy is to wait it out. But if there is a h/w fix or better strategy I’d sure like to know.


There is no HW fix for this as the boards work fine as far as I know. I always make sure the cable is plugged in at power up when I use Ethernet We test these boards before shipping and we have shipped a lot of them and not seen the issue at all.


HI Gerald, I think if the ethernet is plugged in when you power up you will never see the issue - and this is the right workaround to be sure. The issue only occurs if ethernet is either unplugged or replugged, OR if it is taken down by software and then taken back up again. These use cases would be supported by a “fully-functioning” ethernet interface, and and from the postings here it seems they are not working on the current BBB. But it also seems very likely to be a driver problem in the 3.8 kernel, and not a hardware problem.


I would lean toward SW as well.

I just plugged in the Ethernet after boot up. I am looking at


Gerald, would you be able to unplug your ethernet cable for say 15 seconds then plug it back in. Does it bring the lan back up?

In my case it does not on 3 boards running either the latest Angstrom or Ubuntu images.

Worked fine. It was closer to 20 seconds.


That is very interesting! What kind of switch is it plugged into? I am using a little Netgear Gig-E … maybe I should try 10/100 …


Interesting indeed. I am plugged into a 10/100 switch so doubt it is that.

What image are your running on that board Gerald? - if it is not the same as me then it is worth me trying that image. I’d love to narrow down this problem.

I am using a Trendnet TE100-S5. I am actually running right now the 7_4 test image. Before that it was the 6_20 image. No issues there that I can recall.


Oops - now I’m confused by those image numbers. The Angstrom images seem to have 2013-06-06 release numbers so not sure what your numbers relate to.

if it helps uname -a gives me:
Linux beaglebone 3.8.13 #1 SMP Mon May 20 17:07:58 CEST 2013 armv7l GNU/Linux

Do ‘cat /etc/dogtag’ from the shell to see the version or visit tag with your board connected over USB.

It is the date. It is explained at

6_20 is the latest official version.


Thanks guys, I should have spotted that.

On this board, I have Cloud9 GNOME Image 2013.05.20

But the same thing happens on:

Unplugging LAN for more than 5 seconds then doing dmesg | tail shows:
[ 1736.786361] libphy: 4a101000.mdio:00 - Link is Down
[ 1736.905444] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
it never returns

root@beaglebone:~# ifup eth0
udhcpc (v1.20.2) started
Sending discover…
Sending discover…
Sending discover…
No lease, failing

I’m sure I’ve tried it on 06_06 image too but can’t find the card with it on so will download the latest and try again with that.
Will report :slight_smile:

Just to clarify, on mine that was diagnosed with a bad Ethernet, I can transmit packets, but could not receive them. There was never an issue, on all three distros, getting it up to transmit. The Ethernet died after a couple of hours.

Might as well just move onto the 6_20 release.


Not yet, it’s supposed to be delivered today, however have people visiting so may not get to it until later this week.